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wIntegrate v6
The release notes in this section provide information about changes in wIntegrate v6.

wIntegrate v6.4.3
Release Date: November 2018
These release notes provide information about enhancements and fixes in wIntegrate v6.4.3.

Enhancements and fixes in wIntegrate v6.4.3

The following issues were addressed in this release:

Issue
number

Description Component

UWIN-397 In v6.4.3, new script functions and host subroutines were added
to report errors in BASIC programs:

▪ The WIN.CMDSTK host subroutine gathers the
@COMMAND.STACK value.

▪ The LogScreenError script function generates a log for
custom errors.

▪ The corresponding LogScreenError.wis file was also
made available in this release.

Scripting

UWIN-808 In v6.4.3, users can align text and buttons
horizontally and vertically within grid cells. A new
GridCellsAlignment.wis file was added to demonstrate
the alignment functionality.

Scripting

UWIN-1555 When files are transferred to and from the U2 host, a File
Transfer Monitor dialog displays by default. In v6.4.3, users can
select the Suppress File Transfer Dialog option to minimize
this dialog during file transfers.

File Transfers

UWIN-2069 In v6.4.3, the Java client can send log messages to the
wIntegrate server, and these messages can be monitored using
wIntegrate Administrator.

Installation,
Licensing, Thin
Client Deployment

UWIN-2385 In v6.4.3, file transfer speed has significantly increased and file
transfer processes are nearly 15 times faster than they were in
previous versions.

File Transfers

UWIN-2426 In v6.4.3, a MAPI Bridge component was added to support 64-bit
Microsoft Office products. This installation option is available to
use with both local clients and thin clients, and can be installed
on the client machine by selecting the appropriate option on
the installation menu.

External App
Integration

UWIN-2462 In v6.4.3, executable files are digitally signed. Users can now
create Microsoft AppLocker rules with publisher conditions,
which can be generated automatically or created for specific
users or groups, as needed.

Installation

UWIN-2532 In v6.4.3, the wIntegrate Scheduler supports secure SSH
communications.

File Transfers
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Issue
number

Description Component

UWIN-2569 Previously, users who performed a bridge copy (when data
is imported from one MV host and simultaneously exported
to a different host) were not warned when the number of
source items did not match the number of target items and
mistakes were made. Now, when this situation occurs, users
receive a message warning them that these numbers do not
match (unless the target number is *) before the bridge copy is
complete.

File Transfers

UWIN-2590 Previously, the login password did not get passed through the
prompt when users attempted to open the scheduler. This issue
has been resolved in v6.4.3.

File Transfers,
Interface

UWIN-2615 In v6.4.3, an ExtendedButton control has been added to
wIntegrate scripting functionality. This control creates a button
that can have both an image and caption, which can be used to
create modern looking applications (for example, a ribbon-style
menu can be created using this control).

Interface, Setup &
Configuration

UWIN-2619 Previously, the WIN.SMAINT subroutine contained an error
that caused compilations to fail during the host program
installation. This issue has been resolved in v6.4.3.

Host Routines

UWIN-2686 In v6.4.3, the WIN.IMAGE host subroutine and the Draw
Image script command contain new options, which allow users
to save and maintain the aspect ratio of an image.

Host Routines

UWIN-2689 Previously, some file formats that were considered obsolete
were removed from the system. In v6.4.3, the File Import, File
Export, Query Builder, and Spool File formats were returned to
a dBase III format for clients still using dBase III.

File Transfers

UWIN-2697 In v6.4.3, a new parameter was added to the CreateFKeyBar
function that makes is possible for users to add tooltips to
function keys.

Scripting

UWIN-2698 In v6.4.3, users can display multiple function keys in up to three
different function key bars.

Scripting

UWIN-2702 In v6.4.3, users can define, load, and redisplay function keys
in real time. To replace a function key bar, users can run the
DeleteFKeyBar library function to delete the function key
bar prior to creating a new one.

Scripting

wIntegrate v6.4.2
Release Date: December 2017
These release notes provide information about enhancements and fixes in wIntegrate v6.4.2.

Enhancements and fixes in wIntegrate v6.4.2

The following issues were addressed in this release:

Issue
Number

Description Component



wIntegrate v6

4

UWIN-1352 To access the Terminal Type setting, select Setup →
Communications → Windows Sockets → Telnet. This value is used
during the Telnet negotiation phase of the initial connection to a
new host. In this release, the Terminal Type value is automatically
changed when you choose a different emulation in Setup Terminal.
The value is taken from the TelnetTerminal = line in the
emulation .WIT file, and can be customized.

Communications

UWIN-2082 In previous releases, it was difficult to evaluate a new version if you
already had an older version installed. It involved manually deleting
or renaming license .WIL files. In this release, when you install a
newer version as an upgrade and click the radio button for the 10
day evaluation in the Licensing dialog box, the existing full license is
renamed and kept. Later, when you uninstall the evaluation version
and re-install your original version, the program will automatically
recognize the saved full license and prompt you to re-enable it.

Licensing

UWIN-2275 In previous releases, when starting multiple sessions with the
same session .WIC file, you would see the Session Copy dialog
box when starting with the second and subsequent sessions.
This dialog box checked that you intended to start a new session.
Many users considered this dialog box inconvenient, so in this
release the Session Copy dialog box is disabled by default on new
installs. This setting can be changed in Setup → Application →
General. Application settings are put into the registry when the
program is first run, and not by the installer. The settings are
taken from the winteg.wip file which can be customized. When
you start a duplicate session, a copy of the session file is saved in
your Session folder with a name such as Session 1 (Copy
1).wic. Beginning in this release, the copy of the session file is
automatically deleted when you close the session, unless you have
saved it with a different name. This prevents multiple copies of
session files being stored in the Session folder.

Setup &
Configuration

UWIN-2358 The File menu has an option for the Session wizard, which takes you
through the essential settings for a new connection. In the Windows
thin client only, clicking the Next button rapidly could cause the
program to crash. This has been fixed.

Interface

UWIN-2384 The Editor lets you draw dialog boxes and automatically creates
either scripts for execution on the PC, or host Basic programs, if the
interface is to be driven from the multivalued host. The properties
and events of controls are now shown in a new panel on the right
of the window. This makes it much easier to view and change
properties and events.

Editor

UWIN-2423 Prior to this release, when a host was found but the connection
could not be established, the SSL connection displayed a message
similar to the following: [Connection refused]. Under the
same circumstances, the Telnet message would display a message
similar to the following: [Host not found (1)]. In this release,
they both say [Connection refused].

Communications

UWIN-2445 Two new script functions are available to perform a cryptographic
hash. They are Digest, which performs the hash on a variable in
memory, and FileDigest, which provides a hash on a file on disk.
See the Client Scripting Reference Manual for more information.

If you enable the Developer Additions option during installation,
the example script, GetDigest.wis, is installed to C:\Program
Files (x86)\wIntegrate\Example\Script.

Scripting
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UWIN-2495 Information only. wIntegrate is currently built using Microsoft
Visual Studio 2015. Several coding functions have been deprecated
by Microsoft and have now been replaced with their updated
counterparts. Users will see no change in operations.

Code Cleanup

UWIN-2499 Several bugs have been fixed in the Editor.

The WIN.DEMO suite of demonstration host programs has been
enhanced as follows:

▪ Files containing CHAR(0) can now be edited

▪ When editing Basic programs, the @ variables are syntax-colored

▪ Several issues fixed when line endings were set to \n or \r

▪ Folding subroutines recognized MYSUB: as a subroutine label,
but not MYSUB :

Editor

UWIN-2504 The Query Builder and scripting support interaction with Rocket R/
Link using JSON code. Previous versions of wIntegrate would crash
when the JSON processor received non-JSON code. This has been
fixed.

External App
Integration

UWIN-2505 Prior to this release, applications were compiled with Visual Studio
2015 Update 2 (UWIN-2390 in version 6.4.1). In this release the
compiler has been upgraded to Visual Studio 2017. Code was
amended to remove any new warning messages.

wIntegrate v6.4.2 uses Microsoft Foundation Classes (MFC) version
14.10. (Visual Studio 2015 also used MFC but that was version
14.0.) MFC provides the underlying functionality for the product.
wIntegrate automatically installs any required MFC files into system
folders that have not already been installed by other applications.
Occasionally, support personnel have had issues when a new version
of MFC was used. Some MFC issues with "side-by-side assemblies"
can be fixed by downloading and installing the Microsoft Visual C++
Redistributable for Visual Studio 2017.

Third-party Tools

UWIN-2510 When running the wlicense.exe licensing program from
Windows, and a command prompt with an invalid authorization key
is used, the license.wil file would update internally with a blank
key, invalidating the license. This error prevented any subsequent
license updates when using wlicense.exe from command
prompt with a valid key. This error has been fixed.

Licensing

UWIN-2511 This case relates to the Monitor used with the wIntegrate Server as
part of the thin client deployment. When the connections between
the thin clients and the wIntegrate Server were set to use SSL, the
thin client views that were displayed in the Monitor could randomly
stop being updated. In some cases, it would also cause the related
thin client to stop responding. Closing the Monitor caused activity
to resume on the thin clients. This was noticed during internal
stress testing when multiple thin client screens were being updated
frequently. This issue has been fixed.

Thin Client
Deployment

UWIN-2513 A number of minor code issues were fixed for this version. Code Cleanup
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UWIN-2514 Beginning with this release, two new buttons have been added to the
Licensing dialog box. The Details button shows all the information
about the current license. The History button shows all the licenses
that have been installed on the machine. This information is stored
in the License.log and LicenseHistory.log files in C:
\ProgramData\Rocket Software\wIntegrate License
directory.

Licensing

UWIN-2516 Several small enhancements have been made to the Java thin client,
including:

▪ The client version is now displayed in the About dialog box.

▪ The application name on MacOS is now displayed as wIntegrate
Java Client instead of MainView.

▪ In the Scheduler Options, the spin buttons now work as expected.

Thin Client
Deployment

UWIN-2517 The WIN.DEMO suite of demonstration host programs has been
enhanced. New options show how to:

▪ Import data to Excel

▪ Use the Report Viewer to view host data

▪ Create a PDF file

▪ Use constants from the PC such as directories and PC user name

Host Routines

UWIN-2518 In this release, you can paste multiple rows and columns into the
grid to copy data from sources such as Microsoft Excel. The inability
to paste in multiple rows and columns was a regression. This feature
was lost when the grid was changed in version 6.3.3 (UWIN-472). That
case concerned pasting text into a cell, and running the StartEditing
and EndEditing events, which the host requires to know that the
value in the cell has changed.

A new property, MultiplePaste, has been added to the grid to
reintroduce the ability to paste in multiple cells.

This must be enabled to paste multiple rows and columns.

Scripting

UWIN-2519 A benefit of the Java client is that it can run over the internet with a
zero-footprint install. Browsers no longer support Java applets, so
sample files are now supplied explaining how to use Java Web Start
to start Java applications from a browser link using a .JNLP file.
This version includes a .JNLP file that is compatible on Windows,
MacOS, and Linux.

Thin Client
Deployment

UWIN-2522 When using the thin client deployment, the client could crash if it
was connected to a wIntegrate Server, using SSL, and the Inactivity
Timeout option was enabled. This has been fixed.

Thin Client
Deployment

UWIN-2524 The following two example HTML pages, showing the Java client's
browser deployment, have been removed because many browsers
no longer support Java:

▪ wIntJavaPage.htm

▪ wIntJavaPage2.htm

Thin Client
Deployment
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UWIN-2525 In this version, a number of issues with Java Client styles using
stylesheets have been resolved.

An example script WebStyle.wis is installed to the Program
Files (x86)\wIntServ\Example\Script directory. It
shows how stylesheets are used. For more information see the
Installation and Configuration Guide

Thin Client
Deployment

UWIN-2526 The Dialer option on the Run menu was considered obsolete and
has been removed from the menu. The functionality of this option is
still available in the product, so you can reinstate it if necessary. To
enable this option on the menu, see the Troubleshooting section in
the Rocket wIntegrate User Guide.

Scripting, Setup &
Configuration

UWIN-2529 Each cell in the wIntegrate grid supports up to 2,000 characters.
There was an issue that made it possible to paste in over 2,000
characters. In this release, if the user attempts to paste in more than
2,000 characters, the paste instruction is ignored and nothing is
pasted in.

Scripting

UWIN-2530 The Scheduler lets you run saved Query Builder reports in batches
at regular intervals. This version of the Scheduler allows the use of
custom ports for Telnet connections. The default value will remain
23.

File Transfers

UWIN-2535 In version 6.4.2, Telnet connection messages and errors include
the underlying TCP error number appended to the beginning of the
message. For example, instead of showing Connection closed,
you will now see 10053 Connection closed. You can use the
message number to find out more about the event by searching the
web for "Windows Sockets error code 10053".

Communications

UWIN-2537 In version 6.4.2, SSL connection messages and errors include the
underlying TCP error number appended to the beginning of the
message. For example, instead of showing simply Connection
closed by host (1) you might now see 10064 Connection
closed by host (1). You can use the message number to
find out more about the event by searching the web for "Windows
Sockets error code 10064".

Communications

UWIN-2544 This version supports web services using functions to make HTTP
requests to GET, POST, PUT, PATCH, and DELETE. See the Client
Scripting Reference Guide for details.

An example script GetDigest.wis is available in C:\Program
Files (x86)\wIntegrate \Example\Script if you enable
Developer Additions during installation.

Scripting

UWIN-2545 The UserStat utility is installed if the Network Administrator Tools
option is selected during installation. This application shows current
users on the network. It uses the same IP ports as wIntegrate and
the wIntegrate Server, and cannot run at the same time on the
same computer. In this release, UserStat automatically runs as
an administrator, allowing it to check if the wIntegrate Server is
running. If the server is running, UserStat will not to run. This issue is
related to UWIN-2557.

Licensing
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UWIN-2550 If you export a Microsoft Excel spreadsheet from the PC to your host,
the values you see in your multivalued system might be different
than the values you enter and see in the spreadsheet. The example
reproduced had a cell showing a numeric value of 0.07, which is
stored in the Excel .XLSX file as 7.0000000000000007E-2. In this
release, when you export a value stored in exponential notation
to the multivalued host, the resulting field is converted to, in this
example, 0.070000000000000007. Also, a warning is displayed in the
File Transfer Monitor, and a file is written to the Logs folder. See
the Troubleshooting section of the wIntegrate User Guide for more
information.

File Transfers

UWIN-2551 In previous versions, an error message would be displayed when
attempting to connect to a network printer other than the default
one. This has been fixed.

Setup &
Configuration

UWIN-2552 In previous versions of the Scheduler, the automatic login feature
was failing due to a timing issue. A small delay was introduced when
logging in, resolving this issue.

File Transfers

UWIN-2553 In this release, all functionality is supported when connected to
Ultimate Advanced Plus. The two-character MACHINE.TYPE is UL.

Host Routines

UWIN-2555 wIntegrate is a 32-bit application that can communicate with 32-
bit Microsoft Outlook using MAPI (Windows Messaging API) to send
and retrieve emails. However, 32-bit MAPI applications cannot
communicate with 64-bit Outlook running on 64-bit Windows. This is
because a 32-bit application cannot load a 64-bit Msmapi32.dll
file. It is not possible for wIntegrate to communicate with 64-bit
Outlook in the same way on 64-bit Windows.

In previous releases, if you tried to make a MAPI connection to 64-
bit Outlook running on 64-bit Windows, the message Server busy
would be displayed and wIntegrate would become unresponsive.
This has been changed so the program will remain responsive,
despite being unable to work with 64-bit Outlook.

External App
Integration

UWIN-2557 The UserStat utility is installed when you check the Network
Administrator Tools option during installation. This application
shows current users on the network. It uses the same IP ports as
wIntegrate and the wIntegrate Server, and so cannot run at the same
time on the same computer.

In this release, if UserStat is running, wIntegrate and the wIntegrate
Server will attempt to close it as they start. This issue is related to
UWIN-2545.

Licensing

UWIN-2558 Data can be imported from the host to the PC using the Run
ImportFile command, the Query Builder, and the WIN.IMPORT
host subroutine. In previous versions, the Fields parameter was
limited to 1,024 characters. In this release, the limit has been
increased to 2,048 characters.

File Transfers



wIntegrate v6.4.2

9

UWIN-2560 The wIntegrate Server runs as a service, it does not have an interface
of its own. The Administrator is the interface which sets the options
for the wIntegrate Server. A number of cosmetic improvements were
made to the Administrator:

▪ A new Options button was added with the settings for the
Administrator on this machine. Before this release, these settings
were on the Server button which contains the settings for the
wIntegrate Server.

▪ There is a new Logging tab for the logging options.

▪ The Disconnection Timeout setting is now on the Client tab.

▪ Spin buttons were added to the Disconnection Timeout field.

▪ Changes to the Recoverability Message Queue Size setting
could be lost. This has been fixed.

Thin Client
Deployment

UWIN-2562 The following miscellaneous issues were fixed:

▪ In the Java client, some line-drawing characters were not being
combined correctly at small font sizes. This has been fixed.

▪ File transfer error logging now creates log files for errors in the
Service Subroutine.

▪ Cosmetic improvements were made to the Scheduler.

Code Cleanup

UWIN-2564 In v6.3.7, the default session .WIC files were modified to use
Consolas instead of IBSFont for the terminal screen. Switching from
IBSFont solved a blank or white screen issue many users experienced
on Windows 10. In this release, some standard scripts have been
changed to also use Consolas instead of IBSFont.

Character Screen

UWIN-2573 Previously, when using the Java thin client and accessing the
Keyboard definition tab inside the Setup Keyboard dialog box,
clicking a button to set a value would disable the button so it could
not be accessed again. Along with this, the escape key was not
customizable. Both of these issues have been resolved.

Thin Client
Deployment

UWIN-2577 The wIntegrate host programs are supported on all versions of
UniVerse, UniData, D3, mvBase, and Ultimate Advanced Plus. In
previous releases, the script that installed host programs failed when
installing to mvBase. This has been fixed.

Host Routines

UWIN-2579 SSH support in wIntegrate is based on Putty. In this release, the
Putty source code has been upgraded from v0.66 to v0.70. A full
list of changes between these releases can be found here: https://
www.chiark.greenend.org.uk/~sgtatham/putty/. This fixes an
incompatibility issue with recent versions of Linux.

Communications

UWIN-2583 The program could crash if a non-modal child dialog was displayed,
and the first dialog was closed. This has been fixed.

Scripting

https://www.chiark.greenend.org.uk/~sgtatham/putty/.
https://www.chiark.greenend.org.uk/~sgtatham/putty/.
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UWIN-2597 The host file WIN.PROGS (or WIN.PARAMS file pointer) has a
series of subroutines called WIN.PARAM.XX, where XX represents
the host machine type (UniVerse, UniData, etc.). Host programs,
including the WIN.SERVER, call the WIN.PARAM.XX subroutine to
set various parameters.

For users of mvBase, the WIN.PARAM.MV subroutine has been
modified to set the following:

▪ Maximum record size: 9999999

▪ Maximum data size to receive from a PC: 1900

▪ Maximum data size to send to PC: 2049

Host Routines

wIntegrate v6.4.1
Release Date: February 2017
These release notes provide information about enhancements and fixes in wIntegrate v6.4.1.

Enhancements and fixes in wIntegrate v6.4.1

The following issues were addressed in this release:

Issue
number

Description Component

UWIN-677 The program now supports secure FTP using SFTP (that is based
on SSH). This is available in the Run FTP dialog, and in scripting
generally. Only the initial connection is different: the original
FTP commands to get and put files, etc. are still used for secure
FTP. For more information, see the Client Scripting Reference.
See also UWIN-2439 concerning FTPS (that is based on SSL).

Communications

UWIN-680 The Windows thin client now supports Windows Authentication
which can automatically log the user into the wIntegrate Server.
The thin client deployment splits the application into separate
parts running on different computers:

▪ the thin client with its screen-and-keyboard user interface.

▪ the wIntegrate Server with core functionality. This machine
makes the connection to the host.

A disadvantage of the resulting 3-tier architecture is that the
thin client user has to first log into the wIntegrate Server,
and then log into the multi-valued host. To overcome this
inconvenience, the thin client login now supports Windows
authentication to automatically log the user into the wIntegrate
Server. The result is that double-clicking the thin client icon
can take the user directly to the host login, just like using the
local version. For more information see the Installation and
Configuration Guide and the User Guide.

Thin Client
Deployment
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Issue
number

Description Component

UWIN-2034 Some operations, such as the Query Builder, interact with the
host using a BASIC program called WIN.SERVER. If an operation
is unable to execute WIN.SERVER, an appropriate error message
is displayed. This is a common error, particularly for new users
who might not have installed the host programs yet. In this
release, the error dialog has a button More information that
pops up a new dialog describing the cause of the error, and the
steps to correct it.

Installation

UWIN-2134 The wIntegrate Server runs as a service so it does not have an
interface of its own. The Administrator is the interface that sets
the options for the wIntegrate Server. In previous releases,
some changed settings in the Administrator were lost when the
machine was rebooted. This has been fixed.

Thin Client
Deployment

UWIN-2149 The wIntegrate installer can be run silently, that is without any
user interaction. The Installation and Configuration Guide now
describes how to create the license as part of a one-line silent
installation.

Installation

UWIN-2150 When you import data from the host to a spreadsheet on the
PC, you can optionally "explode" multi-valued fields into
separate rows. You can also repeat the values of previous rows
to populate cells that would otherwise be blank in the newly-
created rows. This data manipulation can greatly increase the
size of the original record. In previous releases, if the generated
record exceeded 2MB, an error message was displayed and
the transfer stopped. In this release the generated record can
exceed 5MB. See also UWIN-2411, where the related error
message has been improved.

File Transfers

UWIN-2163 SSH support in wIntegrate is based on Putty. In this release, the
Putty source code has been upgraded from v0.60 to v0.66. A
full list of changes between these releases can be found on the
Putty web site. This is a significant improvement. It fixed a crash
(UWIN-2394) and enabled GSSAPI/Kerberos (UWIN-2257).

Communications,
Third-party Tools

UWIN-2176 Our SSL support is created in-house using OpenSSL. In previous
releases, the relevant files were installed into C:\Windows
or C:\Windows\SysWOW64 (on 64-bit versions of Windows).
In this release, they are installed to C:\Program Files
(x86)\wIntegrate. This reduces the chances of conflicts
with other applications that might use the shared C:\Windows
folder for different versions of files with the same name. The
files are:

▪ openssl.exe

▪ U2libeay.dll

▪ U2ssleay.dll

▪ unisslclnt.dll

▪ uniwincert.dll

Communications
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Issue
number

Description Component

UWIN-2204 Beginning at this release, when exporting data from the PC to
the host, individual fields of up to 32K can be exported. This
matches Excel's limit of 32,767 characters in a single cell of an
.XLSX spreadsheet. In previous releases, the limit was 2K in
.XLSX, .XLS, and .CSV formats. If this was exceeded, the
File Transfer Monitor showed the message Local computer
host buffer overflow.

File Transfers

UWIN-2205 Most text files are stored in ANSI format where each character is
stored as a single byte (depending on your system's code page).
Some programs, like Windows Notepad, let you save text files in
UTF-16 format where each character is stored as two bytes. The
UTF-16 format permits the use of more characters than the 256
supported by ANSI. wIntegrate cannot support text files saved
in UTF-16 format. This is because the program works with host
systems that support only 256 characters, so it would not know
how to process some of the characters it might encounter. In
this release, if you try to use Run ExportFile to export a
file that appears to be in UFT-16 format, a warning message is
displayed.

File Transfers

UWIN-2257 This release supports GSSAPI / Kerberos. This enables you
to log in to your multi-valued host without having to enter a
user name and password. This is supported only on the local
version, and not the thin client. Parameters are set in the new
GSSAPI tab of the Setup SSH Communications dialog. These
parameters are similar to what you see in Putty, as SSH support
in wIntegrate is based on Putty. Note that GSSAPI is an API
and Kerberos is an implementation of this API. Kerberos is
built into the Windows Active directory. Configuring Kerberos
can be a time consuming process. Please use Putty to verify
the Kerberos configuration before using wIntegrate. For more
information, see the Using wIntegrate section on setting up U2
SSH communications.

Communications

UWIN-2262 There was a bug in the SSH communications where the program
could crash when switching quickly between SSH and telnet
communications. This has been fixed.

Communications

UWIN-2295 The supplied host subroutine WIN.PCRUN would fail if the file
path contained a space. This has been fixed.

Host Routines

UWIN-2299 The scripting has constants. They are described in the Client
Scripting Reference. If you enabled Developer Additions
during installation, you can see them by running the script
Const.wis in Program Files (x86)\wIntegrate
\Example\Script. Three of the constants return the Name,
Version, and Extra Information about the operating system. In
Windows 8, 8.1, and 10, the Version and Extra Information have
always returned the same incorrect values of "6.2" and "9200"
respectively. In this release we have changed the way these
values are obtained. The Version and Extra Information are now
returned correctly.

Scripting

UWIN-2330 In the v6.4.1 release, the SSL libraries have been updated to use
the 1.0.2h version of OpenSSL.

Communications
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Issue
number

Description Component

UWIN-2332 In the Windows thin client, clicking the Restore Menu option on
the System menu resulted in a script error and the File → Edit
menu was not restored. This has been fixed.

Interface

UWIN-2345 When you install the host programs, the WIN.PROGS file
contains subroutines beginning with WIN.PARAM. These
subroutines return parameters appropriate for each type of
host. One of the parameters limits the size of a file that can
be transferred to the host. For the fall-back GENERIC machine
type, the subroutine WIN.PARAM specified a maximum host
record size of 32000 bytes. Although nobody should be using
the GENERIC type, this limit goes back some time and is no
longer realistic. So we have increased it to 999999 to match the
smallest size used for other machine types.

See the Host Subroutines Reference for more information about
the WIN.PARAM records.

File Transfers

UWIN-2348 Excel 2007 and later support the .XLSX file format, which
allows up to 16,384 columns and 1,048,576 rows. In earlier
releases, when you imported data from the host to an .XLSX
file, wIntegrate could create a spreadsheet with a greater
number of rows or columns than Excel could support. This
resulted in an error message when the file was opened in Excel.
In this release, if Excel's limits have been exceeded, the transfer
is stopped. A dialog opens and suggests another format to use,
such as CSV (Comma-Separated Values).

File Transfers

UWIN-2352 Some obsolete and unused files are no longer installed. Code Cleanup,
Installation

UWIN-2359 There were some minor cosmetic issues when running the
Query Builder from the Java thin client. These have been fixed.

File Transfers

UWIN-2361 The Check Installation program (wCheck) lets you view and
modify registry entries for the application components. In prior
releases, if the registered file was on a remote machine, the
path name was not displayed correctly. This has been fixed.

Interface

UWIN-2363 Logging can be enabled in many areas of the application. In this
release the logging has been made more consistent with regard
to:

▪ log file locations

▪ naming conventions

▪ format of logged data

▪ automatic deletion of old logs where feasible

For more information see the Installation and Configuration
Guide.

Interface
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UWIN-2369 If you enable Developer Additions during installation, a zip
file, RenameHosts.zip, is installed into the C:\Program
Files (x86)\wIntegrate\Example\Script directory.
This zip file contains a script, sample data files, and instructions
on how to change the host name in session .WIC files for
multiple end users. This would be useful if you want to switch
all users from one host to another very quickly, for example
after upgrading your multi-valued server database from one
machine to another. See the file Instructions.txt for
more information.

Scripting

UWIN-2372 Chapter 4 of the User Guide describes transferring multi-valued
data. This chapter has a new section "Resolving file transfer
issues". The information in this section covers the majority of
the file transfer issues experienced by users.

Documentation

UWIN-2374 When importing data from the host to an .XLSX file on the PC,
numeric fields are by default treated as numbers in Excel. If you
want a numeric field to be stored in Excel as text, you can use
the Left-Justified Is Text check box on the Advanced dialog.
This is useful for long part numbers that might have leading
zeros. In previous releases, the Left-Justified Is Text check box
was also applied to date fields (recognized by the date format
in the host dictionary item). In this release, the check box is
no longer applied to date fields. Note that you can also force
specific dictionary items to be stored in Excel as text or numbers
by using the STRING() or NUMBER() functions. For more
information, see the User Guide.

File Transfers

UWIN-2386 When controlling a dialog box from a host BASIC program, it is
important to reduce the number of round trip communications
between the host and the client. A new host subroutine
WIN.DBSETM improves performance by setting the values of
multiple controls in a single instruction. For more information,
see the Host Subroutines Reference Guide.

Host Routines

UWIN-2388 A customer reported a bug with importing host data, where
numeric fields with the MD4 format resulted in incorrect decimal
places in .XLSX files. We cannot reproduce this issue. We
believe it was fixed in v6.3.2. Please let us know if you see this
issue.

File Transfers, Host
Routines

UWIN-2389 In a recent release, there was a regression where the terminal
screen of the Java thin client no longer used anti-aliasing, which
caused the terminal display to be distorted. Anti-aliasing is a
display technique that smooths the contours of fonts. Beginning
at this release, the Java client terminal screen once again
supports anti-aliasing.

Thin Client
Deployment
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UWIN-2390 Prior to this release, applications were compiled with Visual
Studio 2015 (UWIN-2067 in version 6.4.0). In this release the
compiler has been upgraded to Visual Studio 2015 Update 2.
Following best practices, we amended the code to remove any
new warning messages. As with v6.4.0, the new v6.4.1 uses
Microsoft Foundation Classes (MFC) version 14.0. MFC provides
the underlying functionality for the product. wIntegrate
automatically installs any required MFC files into system folders
that have not already been installed by other applications.
Occasionally, support personnel have had issues when a new
version of MFC was used. Some MFC issues with "side-by-side
assemblies" might be fixed by downloading and installing the
Microsoft Visual C++ Redistributable for Visual Studio 2015.

Third-party Tools

UWIN-2394 Two users reported a crash when using SSH communications
and streaming large amounts of data quickly to the terminal
screen. We could not reproduce this in-house. Both users
reported this fixed after we upgraded the Putty source. Prior to
this release, we used Putty v0.60. In v6.4.1 we use Putty v0.66.
See UWIN-2163.

Communications

UWIN-2395 This task is mentioned for information only. Users should see
no difference in operation. wIntegrate is built with Visual Studio
2015. This tool has a feature called Static Code Analysis that
analyzes source code looking for best practice and potential
issues. We ran the Static Code Analysis on all wIntegrate source
code and made appropriate changes.

Code Cleanup

UWIN-2401 The Editor's automatic formatting has been updated to handle
additional constructs, including:

▪ BEGIN TRANSACTION / END TRANSACTION

▪ OPENSEQ

▪ OPENDEV

▪ COMMIT

▪ ROLLBACK

Also, the File menu has a new option to open the folder
containing the item currently being edited.

Editor

UWIN-2404 The wIntegrate Server runs as a service, so it does not have
an interface of its own. The Administrator is the interface
which sets the options for the wIntegrate Server. In the
Administrator → Options → Server tab, there is a check box
called Use SSL for Connections to this Server. In this release,
when you browse for a certificate, you can select from one of
three certificate stores: My, Root, or CA. See the Installation and
Configuration Guide for more information.

Thin Client
Deployment
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UWIN-2408 The Administrator shows a red warning if SSL tracing is enabled
on the wIntegrate Server it is connected to. SSL tracing is not
recommended for production environments as verbose logs
are written for every connected client, Administrator, and
Monitor. For this reason, there is no option in the Administrator
to enable SSL tracing for the wIntegrate Server. The warning
dialog explains how to disable SSL tracing in the registry and
provides a button to disable it.

Communications,
Thin Client
Deployment

UWIN-2411 When you import data from the host to a spreadsheet on the
PC, you can optionally "explode" multi-valued fields into
separate rows. You can also repeat the values of previous
rows to populate cells which would otherwise be blank in
the newly-created rows. This data manipulation can greatly
increase the size of the original record. If the generated record
exceeded 2MB, the following message was displayed and
transfer stopped:

Maximum host record size exceeded

In this release, this message has been changed to the following:

Host item too big due to Explode / Repeat
Values.

See also UWIN-2150 where the maximum size of the generated
record has been increased.

File Transfers

UWIN-2412 Beginning at this release, the maximum size of an individual
field which can be imported from the host to a PC file is at least
2MB. This would have to be imported into an ASCII or .CSV
file as the maximum size of a cell in Excel is 32K. In previous
releases, wIntegrate limited the length of individual imported
fields to 2K.

File Transfers

UWIN-2413 The wIntegrate Server runs as a service, so it does not
have an interface of its own. The Administrator is the
interface which sets the options for the wIntegrate Server.
In this release, the Log Statistics to File option has been
added to the Administrator → Options → Server tab. This
lets you record the number of users and the amount of
memory used at configurable intervals. The log file is named
wIntServer_Stats_YYMMDD.log, where YYMMDD is the
date. One file is created each day and these files can be deleted
automatically after a configurable number of days. The log
file is stored in C:\ProgramData\Rocket Software
\wIntegrate Server\Logs.

For more information on logging, see the Installation and
Configuration Guide.

Thin Client
Deployment

UWIN-2415 The Editor lets you create dialogs. In previous releases it would
not allow accented characters such as "é" in the dialog caption.
This has been fixed.

Editor
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UWIN-2419 The UserStat.exe application is installed optionally. It
broadcasts a network message and collects responses to show
all wIntegrate users on the network. You can configure the
broadcast address it uses, which can reduce network traffic. In
previous versions, there was a bug where the four broadcast
address bytes were reversed. For example, a broadcast
address specified as 192.168.255.255 would be transmitted
as 255.255.168.192. Because the default broadcast address is
255.255.255.255, this would not be an issue unless the address
had been customized.

Licensing

UWIN-2428 The Query Builder did not adequately describe the versions
of Excel we support. Now, in place of "Excel 2003" and "Excel
2007", these applications are described as "Excel 2003 and
before" and "Excel 2007 and later". Behind these descriptions
are the file formats used. Excel 2003 and earlier used the .XLS
format, while the .XLSX format was introduced in Excel 2007.
This latter format supports more cells and rows.

File Transfers

UWIN-2429 Beginning at this release, an internal buffer has been increased
in size to improve the efficiency of processing received data.

Communications

UWIN-2431 In this release, each time the licensing program updates the
license, two log files are written:

▪ LicenseHistory.log has a list of all updates

▪ License.log stores only the current license

The license.log file can be read by remote administrators
with scripted/shell access. See the Installation and Configuration
Guide for more information on log files and their locations.

Licensing

UWIN-2433 In recent releases, not all executables were code-signed as
coming from Rocket Software. In this release, we code-sign all
the .EXE, .OCX, and .DLL files that are built by the wIntegrate
build process.

Installation

UWIN-2437 All wIntegrate version 6.4.1 applications are certified to work
with Windows Server 2016. This includes the local install version
in addition to the wIntegrate Server and thin clients.

Release Tasks

UWIN-2439 The program now supports secure FTP using FTPS (that is based
on SSL). This is available in the Run FTP dialog, and in scripting
generally. Only the initial connection is different; the original
FTP commands to get and put files, and so on. are still used
for secure FTP. For more information see the Client Scripting
Reference. See also UWIN-677 concerning SFTP (that is based on
SSH).

Communications

UWIN-2443 When running the Windows thin client, the IsShown script
function did not work properly. This has been fixed.

Interface, Thin Client
Deployment

UWIN-2446 The Run → FTP dialog is a fully functional scripted FTP client.
The dialog shows lists of files on the local and remote machines.
In previous releases, the file dates were always shown in the UK
DD/MM/YYYY format. In this release, the date format respects
the regional settings in Control Panel.

File Transfers

UWIN-2447 The FileInfo and FileList scripting functions have a new
option to support locale-dependent date/time formats. See the
Client Scripting Reference  for more information.

Scripting
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UWIN-2448 When connecting to an SSH server for the first time, you are
prompted to accept the SSH key. These keys are stored for
future use in the registry. In this release, there is an option
to clear the saved SSH keys. This might be needed if a server
setting changes and invalidates a stored key. This could
show a security violation message and prevent the user from
connecting. To delete all SSH keys, click the Reset SSH Keys
button in the SSH tab of the Setup SSH Communications dialog.

Communications

UWIN-2451 wIntegrate supports Rocket R/Link as a destination for files
created by the Query Builder. You can also use scripting,
including the multi-valued host, to generally interact with R/
Link servers using the R/Link API. If wIntegrate is unable to
connect to the R/Link server, an error message is displayed in a
pop-up dialog. In this release, the error dialog has been updated
with more meaningful information to assist with the problem.

External App
Integration

UWIN-2454 The wIntegrate Editor supports the Rocket Aldon LM(e) source
control system, which means you can perform common source
control operations from within the wIntegrate Editor rather
than using separate Aldon LM(e) applications. This requires
that the LMU2 installer is run and the LMU2.dll file is present
on the client machine. If this file cannot be located, an error
message is displayed in a pop-up dialog. In this release,
the error dialog has been updated with more meaningful
information to assist with the problem.

External App
Integration

UWIN-2461 A customer reported a serious issue where exporting data from
an .XLSX file to the host resulted in some fields being put into
adjacent records. In the spreadsheet supplied by the customer,
empty cells had an internal format we had not seen before. We
could not reproduce the issue by using Excel to create what
looked like an identical spreadsheet. The program now handles
spreadsheets with this particular anomaly. However, customers
should take care when using files in proprietary formats which
were created by third parties.

File Transfers

UWIN-2467 Most users of the thin client deployment will use Active
Directory to authenticate thin client users connecting to
the wIntegrate Server. This is enabled in the Security tab
of the Administrator → Options settings. If this setting is
not enabled, users are authenticated from a simple text file
users.inf located in the C:\ProgramData\Rocket
Software\wIntegrate Server directory. This list of users
is maintained in the User Management application. In previous
releases, the User Management application listed a maximum of
around 140 users. This was a bug, and this restriction has been
removed.

Setup &
Configuration, Thin
Client Deployment

UWIN-2469 In previous releases, when pasting data from Clipboard into
the character screen, only visible characters and carriage
returns were pasted in. Beginning at this release, you can paste
<tab> characters, CHAR(9), into the host. In some applications
this can paste multiple fields into a host screen. You can
allow or prevent pasting of <tab> characters in the Setup →
Preferences → Options tab.

Character Screen
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UWIN-2470 As part of the thin client deployment, administrators can use
the Service Control Program to start and stop the wIntegrate
Server service. This application now uses User Account Control
and prompts at start-up to be run as an administrator. A user
without administrative privileges has to authenticate at run-
time with administrator credentials.

Thin Client
Deployment

UWIN-2471 The Report Viewer is an output option in the Query Builder. It
lets you display query results in the grid of the pop-up Report
Viewer instead of the terminal screen. The Report Viewer does
not have the 80x24 limitations of the terminal screen, and you
can manipulate columns and rows, and send selections to
applications such as Microsoft Excel and Word. You can use
the Report Viewer as part of your application. To demonstrate
this capability, we supply a demonstration host program,
WIN.IMP.REPVIEW. This imports data from the VOC file and
populates the Report Viewer. WIN.IMP.REPVIEW is part of the
host API. When installing the host programs you should enable
the Host API check box to install this program.

Host Routines

UWIN-2473 During installation of the host programs, the WIN.PCRUN
program showed a warning error similar to the following when
compiled:

WARNING: Variable 'STX' never assigned a
value.

This has been fixed.

Host Routines

UWIN-2475 The Host Subroutines Reference Guide has a new appendix
"Interaction between the host and an emulation .WIT file". The
example shows a host BASIC program asking the client PC for
the following:

▪ all wIntegrate license information

▪ Windows user name

▪ PC operating system

These examples return simple constants. For more information
on constants, see the Client Scripting Reference . The
functionality can be extended with client-side scripting.

Licensing

UWIN-2476 When you import or export data from/to the host, the File
Transfer Monitor is displayed to show progress. If the transfer
fails, this dialog displays an error message in a red font.
This message is lost when you click Exit and close the File
Transfer Monitor. In this release, any error messages shown
in the File Transfer Monitor are recorded in a log file called
FT_YYMMDD_HHMMSS.log, where YYMMDD is the date and
HHMMSS is the time. See the Installation and Configuration
Guide for more information on log files and their locations.

File Transfers
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UWIN-2479 The Editor displays tips on subroutine parameters as you
are editing them. The parameters are stored in text files
with a .WEB extension. By default, these files are stored in
Documents\wIntegrate\wIntEdit\BasicTips.
You can customize this location in Tools → Folder Options
so all developers use the same file(s) on a central server.
You can create your own custom .WEB files describing your
own subroutines. For more information, see the "Using and
Customizing Intellisense" in the Client Scripting Reference,
Appendix B.

Editor

UWIN-2480 The installer for the wIntegrate Server now uses User Account
Control and prompts at start up to be run as an administrator.
A user without administrative privileges has to authenticate at
run-time with administrator credentials.

Installation

UWIN-2487 On the WIN.DEMO host program demonstration, option 10
runs the BASIC subroutine WIN.LOOKUP. This displays a dialog
and lets you make a choice from a list. This release has a
new example lookup program, WIN.LUDEMO2. This is more
sophisticated and populates the list one page at a time, driven
from the host. When you run the program, instructions are
displayed.

Host Routines

UWIN-2490 In scripting, the ColorButton control supports text alignment
and the BS_FLAT style. For more information, see the Client
Scripting Reference.

Host Routines,
Scripting

UWIN-2501 A customer reported an issue when the font was changed on a
dialog that had already been shown. This issue caused a crash
after a large number of iterations. The cause could be seen by
opening Task Manager, clicking the Details tab, right-clicking
the column headings, and selecting the GDI Objects column.
There is a maximum of 10,000 GDI Objects per process and
wIntegrate was exceeding this limit. This was fixed by changing
the way internal resources are allocated.

Scripting

wIntegrate v6.3.7
Release Date: April 2015
These release notes provide information about enhancements and fixes in wIntegrate v6.3.7.

Enhancements and fixes in wIntegrate v6.3.7

The following issues were addressed in this release:

Issue
number

Description Component

UWIN-189 In v6.3.7, two new script functions, Monitor and Monitors,
have been added. These functions return information about the
monitor or monitors as specified by the option parameter.

For more information about these script functions, see the
Client Scripting Reference guide.

Scripting
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UWIN-464 Previously, the default wIntegrate session files used a custom
font called IBSfont. IBSfont is a raster font created many years
ago, and does not scale to larger sizes. Windows now uses
TrueType fonts which are scalable and install differently than
the older bitmapped fonts.

As of v6.3.7, the wIntegrate session files now use Consolas by
default. Consolas is fixed pitch, like IBSfont, which is necessary
for terminal screens. As a TrueType font, it automatically scales
to fit the newer large screens, whereas IBSfont can fill only part
of these screens.

Terminal Emulation

UWIN-718 Support for SSH in wIntegrate is based on Putty. Putty supports
KeepAlive, where a meaningless packet is sent periodically
to the host to prevent it from closing the connection due to
inactivity.

Support of KeepAlive has been added to v6.3.7 of wIntegrate in
SSH communications. If KeepAlive is selected in Setup > SSH
Communications, you can enter the interval time in seconds to
send the packets.

Communications

UWIN-735 In v6.3.7, the wIntegrate Editor can be integrated into a host
source control system by using a custom EditCheck subroutine
that you create on the host. This subroutine can be named
anything that you want. It is called when downloading,
uploading, and closing a file that is being edited on the host.

For information about setting up the EditCheck host subroutine,
see Appendix B of the Client Scripting Reference guide.

Host Routines

UWIN-1275 As of v6.3.7, the SSL libraries have been updated to use the
1.0.1j version of OpenSSL. These libraries address problems
with the "heartbleed" and "POODLE" bugs, along with more
general enhancements and issues concerning SSL.

Communications

UWIN-1291 In v6.3.7, a new style has been added to the GraphicButton
control called GBS_CENTER. The GBS_CENTER style centers
the image inside the button area. This disables the automatic
scaling of images.

Scripting

UWIN-1292 In previous versions of wIntegrate, you can hide a row or
column in the grid, but cannot test whether a row or column
was hidden. As of v6.3.7, four methods have been added to the
Grid control to allow testing of hidden rows or columns:

▪ GetColHidden

▪ GetColsHidden

▪ GetRowHidden

▪ GetRowsHidden

Scripting
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UWIN-1293 The grid supports the ability to hide rows and columns. In v6.3.7
you can now determine the first column or row visible and the
number of rows or columns visible.

Two properties, LeftIndex and TopIndex, have been added
to the Grid control and return the column or row number
of the first visible column or row in the grid. Two methods,
GetVisibleCols and GetVisibleRows, get the number of
completely visible columns or rows in the grid.

Note that these new properties and methods are not supported
in the Java Client.

Scripting

UWIN-1295 In v6.3.7, an executed script can reference variables in the
script which executed it. The Execute script command
now has two new options, L and R, which allow the script to
reference variables in the script that ran the Execute. For
more information about these options, see the Execute
section in the Client Scripting Reference guide.

Scripting

UWIN-1318 The wIntegrate Monitor allows authorized users to see active
user sessions in real time. In previous versions, a cosmetic
bug existed where a client screen could be displayed after the
session was closed. This issue has been fixed in v6.3.7 and the
Monitor now properly blanks the client's session display when
the client disconnects.

Thin Client
Deployment

UWIN-1330 The wIntegrate Administrator is the interface to the wIntegrate
Server, which runs as a service and so has no interface of its
own. The Administrator can be run by the user on the machine
that is running the Server or by remote users. It has a dialog to
show all users logged in to the Administrator.

In previous versions, the list showed the IP address and the
user name of each user, but the user name was blank for a user
logged in to the Administrator on the same machine which was
running the wIntegrate Server. In v6.3.7, the Administrator user
name is now populated as "Server machine."

Thin Client
Deployment

UWIN-1752 In v6.3.7, wIntegrate Server error reporting for thin clients has
been improved.

Thin Client
Deployment

UWIN-1823 In v6.3.7, the host programs now use CRT instead of PRINT.
CRT displays text on the screen regardless of PRINTER ON/OFF
status.

Host Routines

UWIN-1894 In v6.3.7, dialogs can automatically scroll to the field with
focus if the field is out of view on a large dialog with scroll bars.
The "S" option has been added to the DialogBox Option
command to allow scrolling to the control with the focus into
view if it is not visible. The control must support the SetFocus
event. If a control does not have this event in its list of events,
it will not be scrolled into view. Any buttons, check boxes, and
radio buttons on the dialog must include the BS_NOTIFY style.

The Java Client uses a slightly different algorithm to move
controls into view, so positioning after a scroll might be slightly
different.

Scripting
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UWIN-1907 In previous versions of wIntegrate, the ComboBox control
supported only three styles:

▪ CBS_SIMPLE, which displays the list box at all times

▪ CBS_DROPDOWN, which allows the user to pull down the list

▪ CBS_DROPDOWNLIST, which is an alternative version of
CBS_DROPDOWN

In v6.3.7, a new option, CBS_AUTOCOMPLETE, automatically
shows the list as you type, displaying the first item which
matches the text typed so far and adding the rest of the text to
the edit box selected so it can be easily used or over-typed.

Scripting

UWIN-1915 A new example script, SockControl.wis, is installed in the
C:\Program Files (x86)\wIntegrate\Example
\Script folder. It shows how a session can send or receive
data to or from a second socket connection.

Scripting

UWIN-1921 In v6.3.7, a new script command, HotSpot ClickAction,
has been added that allows additional click actions such as Ctrl,
Shift, and Ctrl+Shift on an existing hot spot. The host subroutine
WIN.HOTSPOT has equivalent new options.

Host Routines,
Scripting

UWIN-1923 In previous versions, a bug existed in the Report Wizard that
caused it to reuse a cached report if you logged to a different
account and the report ID was the same. This meant that the
report from the old account was previewed after logging to the
new account where a different report happened to have the
same ID. In v6.3.7, this has been fixed, and the cache now uses
the account name and port to ensure that the old cache is not
reused in a different account.

File Transfers

UWIN-1958 As of v6.3.7, when you install the manuals using the custom
option, you can search the entire documentation set by
selecting Edit > Advanced Search in the PDF, or using Ctrl+Shift
+F. The search will show results from every applicable PDF.

Documentation

UWIN-1962 A new optional flag HostCommandMapChars has been added
to the terminal emulation text files in v6.3.7. This is optional
for backward-compatibility. It defaults to Yes (the existing
behavior). To prevent character mapping in script commands
sent from the host, it should be set to No.

This is relevant for users who select the Finnish, German, and
Swedish language Extensions in Setup > Terminal. For more
information, see the relevant .WIT files in the C:\Program
Files (x86)\wIntegrate\wIntSys\Wit_Ext
folder.

Host Routines,
Terminal Emulation

UWIN-1969 In previous versions, the ADDS Viewpoint emulation did not
properly display some graphics characters. This issue has been
fixed in v6.3.7.

Terminal Emulation

UWIN-1970 In previous versions, the Wyse50 Viewpoint emulation did not
properly display some graphics characters. This issue has been
fixed in v6.3.7.

Terminal Emulation

UWIN-1994 In v6.3.7, the WIN.SSUB2 sample service subroutine has been
enhanced to show how to use a user's credentials to restrict
importing and exporting data for specific files.

Host Routines
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UWIN-2001 When the vertical scroll bar was displayed, an occasional bug
occurred that incorrectly displayed the scroll bar as being too
wide, taking up over 50% of the width of the terminal screen.
This bug was not able to be reproduced in-house, but a solution
has been implemented that should prevent this bug from
reoccurring. If you see this error, please report it and contact
support.

Terminal Emulation

UWIN-2002 As noted in UWIN-464 above, the default session files now use
the TrueType font Consolas instead of the previous IBSfont. In
previous releases, when you used any font other than IBSfont, if
you switched from 80 to 132 columns and then back to 80, your
custom font choice was not respected. This bug has been fixed.

Terminal Emulation

UWIN-2005 As of v6.3.7, wIntegrate uses the 1.0.1j version of the SSL
libraries. These libraries support SSL protocols TLSv1.1 and
TLSv1.2. The new protocols are alternatives to the existing
protocols SSL3 and TLS. The Setup > SSL Communications
dialog has been updated to include these new protocol options.

Communications

UWIN-2021 In v6.3.7, the communication error messages have been
improved and made more consistent. They are described in
Appendix C of the User Guide.

Communications

UWIN-2052 A bug was reported in SSH communications that caused
"[Internal error]" to display when using the wIntegrate thin
client to connect and changing the parameters on the session
between telnet and SSH a few times. This has been fixed in
v6.3.7.

Thin Client
Deployment

UWIN-2058 The wIntegrate Query Builder and Report Wizard can export
data to Microsoft Word. When Microsoft Word's Object Model
changed in the Office 2010 release, a new SaveAs2 method was
added. In the Office 2013 release, the original SaveAs method
was removed. This caused the Query Builder and Report Wizard
export to Word to fail with Office 2013.

In v6.3.7, the library TSVlib.wis has been changed to use
either the SaveAs or SaveAs2 method depending on the version
of Word. This library is used by both the Query Builder and
Report Wizard, so both should now work with Microsoft Word
2013.

Scripting

UWIN-2061 In the v6.3.6 release, a new feature was added that created
error logs whenever a script error occurs. Because script errors
might happen frequently for developers, the Documents
\wIntegrate folder would quickly fill with error logs,
obscuring the meaningful files in this folder. In v6.3.7, the error
logs have been moved to a dedicated folder, Documents
\wIntegrate\wIntError, to resolve this problem.

Other

UWIN-2064 A memory leak of 24 bytes occurred when FTP attempted to
connect to a server, but the connection failed for any reason.
This has been fixed.

Scripting
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UWIN-2071 wIntegrate has always supported Active mode by default for
FTP connections. This v6.3.7 release also supports Passive
mode.

FTP uses two ports – one for commands and one for sending the
data. In Active mode, the client establishes the command port
and the server determines the data port. In Passive mode, the
client determines both the command and data ports.

For developers, v6.3.7 has the related script command, Ftp
Connect2, which opens an FTP connection to a remote FTP
site. This command differs from the Ftp Connect command
in that it offers more advanced connection options such as
Passive mode. If Passive is set to True, this parameter will cause
a Passive FTP connection to be opened.

Communications

UWIN-2072 In previous versions, when you were painting a dialog box
with the wIntegrate Editor, double-clicking a common control
might not have picked up styles or events previously set on the
control. This issue has been fixed in v6.3.7.

Other

UWIN-2077 In v6.3.7, the wIntegrate licensing mechanism can support up to
65,000 users. In previous releases, the limit was 9,999 users.

Licensing

UWIN-2092 In the Windows thin client, the Setup > SSL Communications
dialog now optionally supports tracing. You can choose to trace
Basic, Detailed, or All communications. Tracing should be used
with caution as the trace files can grow to any size on disk. Note
that the tracing option only remains enabled for the duration
of the connection with a wIntegrate Server. The next time you
show the thin client login dialog, the tracing options will be set
to None.

Communications

wIntegrate v6.3.6
Release Date: July 2014
These release notes provide information about enhancements and fixes in wIntegrate v6.3.6.

Enhancements and fixes in wIntegrate v6.3.6

The following issues were addressed in this release:

Issue
Number

Description Component

UWIN-665 Attributes that are defined as MDn (numeric) can be listed to a
HOLD file where they are shown right-justified. Using the Report
Wizard to import the HOLD file and the Report Viewer to view
the data, these numeric fields remain right-justified. However if
the output target is PDF, the numbers were left-justified like all
other text. In v6.3.6, the numeric fields are right-justified.

File Transfers
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UWIN-710 When a script error is encountered, the Script Monitor appears.
This is quite technical and most users simply dismissed it, so
all of the information was discarded and developers lost the
opportunity to fix the error.

In the v6.3.6 release, the program automatically writes an error
log text file to the Documents\wIntegrate folder when a
script error occurs. The file name is wIntError_YYMMDD_R,
where R is a rolling number to give the file a unique name in
the event of multiple errors on that day. The error dialog now
displays text saying that the error log has been written to the
folder. Developers can replace the last line of the displayed text
with a custom message displaying specific instructions, such as
contact information for the Support department.

The optional custom message is stored in the Application folder,
usually C:\Program Files\wIntegrate. The file name is
ScriptErrorMessage.txt. The message can be up to four
lines on the error dialog.

Scripting

UWIN-729 In v6.3.6, you can display the full headings of imported data
regardless of the field width that is specified in the dictionary
item. From the Query Builder or Run > Import File, you can
click the Advanced button and select the Show Complete Field
Headings check box to show the full field headings.

File Transfers

UWIN-825 A new example script, PDFView.wis, has been created that
allows you to open a PDF file and display it in a resizable dialog.
It is in the Program Files(x86)\wIntegrate\Example
\Script folder when you select Developer Additions during
installation. This script requires Adobe Reader as well as the
availability of the Adobe component AcroPDF.dll, which is
installed with Adobe Reader.

Scripting

UWIN-1145 Previously, if you opened several wIntegrate Editor sessions, the
Editor opened in the same spot on your screen, which made it
difficult to see that multiple sessions were opened. As of v6.3.6,
when you open several Editor sessions, the Editor opens slightly
offset to the previous session.

Other

UWIN-1319 As of v6.3.6, the Monitor allows you to filter and sort the
connections that are being viewed. Wildcards (*) allow you to
filter based on user names, and you can also specify login date/
times to sort by.

Thin Client
Deployment

UWIN-1326 The Server tab on the wIntegrate Administrator now has a
Disconnection Timeout option. This option is used when the
recoverability option is not enabled on the Recoverability tab.
If the Disconnection Timeout check box is selected, you can
specify how long to keep a host session active after a client has
disconnected unexpectedly, for example due to a broken WiFi
connection. After this timeout period, the wIntegrate Server will
close the server connection, possibly leaving host files or items
locked. The allowable range of seconds is 30-86,400 (24 hours).

Thin Client
Deployment
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Description Component

UWIN-1449 When wIntegrate was opened by an HTML web page using
Automation, and the menu bar was hidden using JavaScript, the
menu bar would disappear, but the underlying command bar
would remain. There is no change to the product to prevent this,
but there is a way to prevent it using JavaScript in the HTML
web page:

var wIntApp = new 
ActiveXObject("wIntegrate.document"); 
 ... 
 // This makes the menu bar completely disappear 
after being turned off 
 wIntApp.Resize(wIntApp.Width
        + 1, wIntApp.Height + 1); 

Scripting

UWIN-1450 When wIntegrate was opened by an HTML web page using
Automation to perform required operations and then closed, a
dialog box appeared asking the user whether they want to save
changes to wIntegrate. This dialog box no longer appears.

This dialog box is not the same as the standard wIntegrate
Confirm Exit dialog box. To prevent the Confirm Exit dialog box
from appearing as well, the following JavaScript can be used in
the HTML web page:

var app = new ActiveXObject("wIntegrate.document"
);
  session = app.Session;
  ...
  session.SettingsDialog = "SetupApplication";
  session.Setting("ConfirmExit") = "0";

This JavaScript will change the setting for all wIntegrate
sessions.

Thin Client
Deployment

UWIN-1723 The wIntegrate documentation has been updated in v6.3.6. The
content from the Administration Manual has been moved to the
wIntegrate User Guide and a new guide, wIntegrate Installation
and Configuration. All content and screen shots have been
updated to reflect v6.3.6.

Documentation

UWIN-1747 In previous versions, the objects on dbcolors.wis and
dbstyle.wis example dialogs disappeared when the virtual
keyboard was used. This issue has been fixed.

Scripting

UWIN-1812 The IsApp script command checks if an application is running.
It can be run from the U2 host with the WIN.APP subroutine.
wIntegrate is a 32-bit application. In this release, when
wIntegrate is running on 64-bit systems, it can see both 32-bit
and 64-bit applications.

Scripting

UWIN-1852 A memory leak of about 160 bytes occurred on the wIntegrate
Server every time a user session was closed. This issue has been
fixed.

Thin Client
Deployment
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UWIN-1857 The following commands now have a new optional parameter
that returns a success or failure flag:

▪ Ftp Delete

▪ Ftp DeleteDir

▪ Ftp CreateDir

The new variable is optional for backward-compatibility with
existing scripts. If the parameter is specified and the command
attempt was successful, it will be set to "". If the command
attempt was not successful, the variable will be set to an error
message. If the parameter is not specified, then the current
behavior remains where the script error dialog is shown on
failure.

File Transfers

UWIN-1858 The wIntegrate Administrator lets you specify that Thin Client
connections should be secured by SSL. In v6.3.6, if the SSL check
box is selected, then an SSL certificate must be entered. There is
a button to browse for certificates.

Thin Client
Deployment

UWIN-1865 The Spool File option has been removed from the Run
menu in wIntegrate v6.3.6. The option can be added back by
uncommenting around line 90 in the NewSess.wis file in the
C:\Program Files\wIntegrate\wIntSys\Script
folder.

File Transfers

UWIN-1869 When wIntegrate was launched from a web page, using the File
> Save As option caused wIntegrate to crash. This issue has
been fixed.

Terminal Emulation

UWIN-1884 In v6.3.6, you can create an installation log by using a command
line option that shows what files were installed and how the
Registry was updated. For example, you can create a log for
Setup.exe in the C:\Temp\wint_install.log file by
using the following command line:

Setup.exe /v"/l*v \"C:\Temp\wint_install.log
\""

The /v command causes parameters to be passed to the
embedded .MSI files.

Installation

UWIN-1904 It is now possible to automatically terminate a thin client
user session after a specified time. The Server tab on the
Administrator's Options dialog now has a Disconnection
Timeout option that is used when the recoverability option is
not enabled on the Recoverability tab. If the Disconnection
Timeout check box is selected, you can specify how long to
keep a host session active after a client has disconnected
unexpectedly, for example due to a broken WiFi connection.
After this timeout period, the wIntegrate Server will close the
server connection, possibly leaving host files or items locked.

Thin Client
Deployment
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UWIN-1911 The wIntegrate Editor now works with the Aldon LM(e) source
control system, which means that you can perform common
source control operations from within the wIntegrate Editor
rather than using separate Aldon LM(e) applications. The
supported operations include:

▪ Check out

▪ Check in

▪ Cancel check out

▪ Get latest version

▪ Add to source control

▪ Mark for deletion in source control

▪ Open a file from source control

▪ Check in files by task

For more information about the supported operations, see
“Using the Editor with Aldon LM(e) source control” in wIntegrate
Client Scripting Reference.

Other

UWIN-1912 Prior to v6.3.6, the Editor was performing Replace All
functionality incorrectly by replacing the text multiple times.
This issue has been fixed, and Replace All functionality works as
expected.

Other

UWIN-1933 The grid allows the developer to delete columns using the
DeleteCols function. There was a bug where this function did
not always delete the specified columns. This has been fixed.

Scripting

wIntegrate v6.3.5
Release Date: April 2014
These release notes provide information about enhancements and fixes in wIntegrate v6.3.5.

Enhancements and fixes in wIntegrate v6.3.5

The following issues were addressed in this release:

Issue
Number

Description Component

UWIN-840 A new option, Prevent Session Exit While Port Open, has
been added to the Setup > Preferences dialog box, on the
Options tab. If this option is set, the user cannot exit the
wIntegrate application unless the host session is logged out,
and the connection is closed. This works in a similar way to the
script StopExit.wis, which was not on the menus and was
therefore difficult to set up for non-technical users.

Terminal Emulation

UWIN-851 WIN.LOOKUP displays a dialog box where you can select
a line in a list box. Your selection is then returned to the
controlling Basic program. In this release, a new routine
WIN.LOOKUPM allows more than one line to be selected. See
the Host Subroutines Reference Manual for details.

Host Routines
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UWIN-858 In this release, you can store an Excel formula in a field
in the multi-valued database. When the field is imported
into an Excel file along with regular data, the formula takes
effect and performs its calculations. We have enhanced
Run > Import File and Run > Query Builder to support
the FORMULA(<dict_item>) qualifier. This works
in the same way the NUMBER(<dict_item>) and
TEXT(<dict_item>) qualifiers, which force fields to be
treated as a number or text respectively. You can try this by
setting up the following dictionary item. (In UniVerse, @NI
returns the line count of the currently displayed item, so the
definition in line 0002 below results in C1*D1 for the first line of
data, and C2*D2 for the second line, and so on.

ED DICT ORDERS ORDER.TOTAL
0001: I
0002: "C":@NI:"*D":@NI
0003:
0004:
0005: 6R
0006: S

Then run the following query in Run > Import File or Run >
Query Builder to get the data into Excel.

SORT ORDERS CUST.NAME UNIT.PRICE QUANTITY FORMULA
(ORDER.TOTAL) COL.HDR.SUPP

The result in Excel:

▪ Column A has the item ID

▪ Column B has CUST.NAME

▪ Column C has UNIT.PRICE

▪ Column D has QUANTITY

▪ Column E has the ORDER.TOTAL formula multiplying
Column C on the same line (UNIT.PRICE) by Column D on
the same line(QUANTITY).

File Transfers

UWIN-1142 There is a Help button in the Editor's Tools > Preferences
menu. Clicking this Help button resulted in the error "Failed to
launch help." This has been fixed.

Other

UWIN-1294 A new grid method ResetToDefaults sets the styles and
controls of the data in a grid to the default values for the column
or the grid for styles not set on a column. It does not change
the displayed data. Defaults being the current default settings,
which are set with SetColWidth, SetColBackColor, and
so on.

Scripting

UWIN-1314 The Run > FTP dialog box has list boxes showing the files that
are available for transfer between the client and the remote
machine. Timestamp and size information is now shown
for each file. The list boxes have horizontal scroll bars that
disappear when the dialog box is resized. See UWIN-1539.

Scripting
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UWIN-1372 The Run > FTP dialog box has list boxes showing the files that
are available for transfer between the client and the remote
machine. You can select multiple files by clicking each one
individually. In this release, you can also select multiple files by
clicking one file, then pressing Shift and clicking another file in
the list.

File Transfers

UWIN-1431 The Edit > Record menu option lets you capture incoming data
in various formats. One format is Two-way, which records both
incoming and outgoing data. In previous releases, the two-way
recording looked like the following example, where the arrows
show the outgoing (<) and incoming (>) data:

< W
> W
< H
> H
< O
> O
> 1952 UV From myserver\davidr

The same recording now shows the following, which is much
more meaningful. Between the five columns are not spaces,
but tabs, which cause the data to be automatically parsed
into columns when the data is copied and pasted into Excel.
Also, the dates and times are in formats that are automatically
understood by Excel. The third column is milliseconds:

2014-02-23 12:54:56 752 < W
2014-02-23 12:54:56 814 > W
2014-02-23 12:54:56 939 < H
2014-02-23 12:54:57 001 > H
2014-02-23 12:54:57 189 < O
2014-02-23 12:54:57 251 > O
2014-02-23 12:54:57 750 <
2014-02-23 12:54:57 813 >
2014-02-23 12:54:58 062 > 1952 UV From
myserver\davidr

Communications

UWIN-1497 WIN.MSGBOX or WIN.MSGBOX2 are used to display messages.
Under some circumstances, it was possible for incorrect data to
be passed back to the input. The WIN.GETDATA routine had
some code to prevent this from happening. We have added this
code to WIN.MSGBOX and WIN.MSGBOX2.

Host Routines

UWIN-1539 Some users of the FTP dialog box had files whose names were
too long to be viewed in the list box. The dialog box can now be
dragged bigger and the list boxes are resized.

Scripting
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UWIN-1727 Enhancements have been added to the Editor.

▪ On the File > Open From Host dialog box, there are now
buttons to let you browse the host for files and items.

▪ When editing a Basic program, you can right-click a keyword
and select Help on Basic keyword. This shows the same
help as entering, for example, "HELP BASIC CRT" at TCL.
When connected to UniData, the first character of each line
was missing. This has been fixed.

▪ When using File > Open, the Editor remembers the extension
of the last file opened unless the last file opened was "All
Files (.)" Then the next time it defaulted to .WIS. It now
remembers all files in the same way as other file types.

▪ This point is relevant if you are using the U2 / Aldon LMe
integration for source control and lifecycle management. If
you are logged in to an LM server, the status bar now shows
the LM server and working folder.

Other

UWIN-1732 The wIntJavaApplet.jar Java client file can work as both a
plug-in on a browser page and as a stand-alone application with
a similar look and feel as the regular Windows version. When
run as a stand-alone application, the user can drag a border or
corner to cause the window to be resized, and an appropriate
smaller/larger font is automatically selected. This works the
same way in the Java client as the Windows version. When
resizing the window, the Java client did not always snap to size
correctly. It sometimes left a small black border on the right side
or bottom of the window. This has been fixed.

Thin Client
Deployment

UWIN-1746 There is a bug on Microsoft touch screens where right-clicks
are not recognized in applications built with Microsoft Visual
Studio 2010. This can be seen on the Surface Pro. By default, the
right-mouse button displays the Copy menu. However, when
the right-click is invoked in wIntegrate on the Surface Pro, the
Copy menu is not displayed. Instead, it causes a <CR> to be
sent to the host, and sometimes the clipboard contents also.
In previous versions, the workaround was to assign the script
CopyMenu.wis (which display the Copy menu) to a different
key combination, for example Alt + R. In this release, we have
implemented some code from Microsoft to fix the issue.

Setup and
Configuration

UWIN-1765 In this release, all functionality is supported on D3. Host Routines
UWIN-1773 D3 Enterprise Licensing is supported. Enterprise Licensing

allows a single desktop computer to have several connections
to a D3 server but consume only one D3 license. To
use Enterprise Licensing, you must go to the Setup >
Communications dialog box for either SSH or Windows Sockets
(Telnet), display the Telnet tab, and select the D3 Enterprise
Licensing check box before connecting to your D3 server. D3
Enterprise licensing is not supported with SSL connections.
The local version, Windows thin client, and Java thin client all
support D3 Enterprise Licensing in the same way.

Communications
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UWIN-1778 The program already supports type-ahead within a single dialog
box, which is essential for rapid data entry. The issue here is
type-ahead between dialog boxes. For example, when entering
an order, the user will pop up a dialog box to search for the
product, choose one, and then expect to enter data in the main
dialog box before the popup has disappeared. In this release,
type-ahead can be carried from one dialog box to another;
however, some conditions must be met. Type-ahead between
dialog boxes only occurs from a parent dialog box to a child
dialog box and vice versa. Also, the child dialog box has to be
shown using one of the navigation keys set up for the parent
dialog box, and both dialog boxes must use the same field-to-
field navigation keys (for example, Tab or CR).

Scripting

UWIN-1782 In this release, all functionality is supported on mvBase. Host Routines
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UWIN-1783
UWIN-1784

New keywords have been added to UniVerse Basic since the
wIntegrate host programs were written. Some of these perform
functions dramatically faster than the existing code. For
example, a customer reported that it was taking 40 minutes
to build 45,000 rows of data and display them in a grid. We
have now created new versions of some host programs to
use the Basic CHANGE command (which was introduced after
the original code was written). With the customer's example,
the time taken was reduced from 40 minutes to 30 seconds.
Four new routines have been added that use different Basic
commands to convert characters. Testing showed that these
routines are only faster for large amounts of data due to an
overhead in starting up. So the current routines have been
left untouched as to not adversely affect users of the existing
routines.

The new routines are:

1. WIN.DBSETPRPL

This routine sets a property in a Windows dialog box. The
existing routine is WIN.DBSETPRP. Time comparisons for
45,000 records with 6 fields:
WIN.DBSETPRP: 949 seconds
WIN.DBSETPRPL: 26 seconds

2. WIN.DBGETPRPL

This routine gets a property in a Windows dialog box. The
existing routine is WIN.DBGETPRP. Time comparisons for
45,000 records with 6 fields:
WIN.DBGETPRP: 1708 seconds
WIN.DBGETPRPL: 755 seconds

3. WIN.SETLISTL

This routine changes the AM and VM delimiters in a variable
to CR and TAB. The existing routine is WIN.SETLIST.
Time comparisons for a record with 1,000 attributes and
100 values:
WIN.SETLIST: 191 seconds
WIN.SETLISTL: 5 seconds

4. WIN.GETLISTL

This routine changes the CR and TAB characters in a
variable to AM and VM delimiters. The existing routine is
WIN.GETLIST. Time comparisons for a record with 1,000
attributes and 100 values:
WIN.GETLIST: 505 seconds
WIN.GETLISTL: 292 seconds

Host Routines
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UWIN-1785 In the past, we supported most of the multi-valued databases.
As we have not had access to many of these machines for
several years, we are no longer able to support them. So in this
release, the supported host machine types have been changed.
The supported types are:

▪ GENERIC: vanilla multi-value/Pick

▪ AP: D3

▪ MV: mvBase

▪ UC: UniData (P mode)

▪ UD: UniData

▪ UP: UniVerse (Pick flavor)

▪ UV: UniVerse (Ideal and Prime flavors)

Support for mvBase is new in this release. The host programs
for the removed machine types are still installed to the server
in case anybody still wants them, but they are not visible in the
interface. We will remove these programs in a future release
when we have not had adverse feedback from customers about
removing the options from the interface. The removed options
are:

▪ GA General Automation (R91)

▪ IN IN2

▪ MD McDonnell Douglas

▪ ME ADDS Mentor

▪ PI PI/Open

▪ PR Prime Information (Primos

▪ SQ Sequoia

▪ UL Ultimate

Host Routines

UWIN-1787
UWIN-1809

The Report Wizard is supported on D3 and mvBase. The Report
Wizard lets you see host print reports as thumbnail views,
then select one and download it to the PC in popular formats
such as Excel. Until this release, the Report Wizard was only
supported on UniVerse and UniData. It is now also supported
with D3. In order to get this to work, we had to create a new host
subroutine and enhance the script command GetFromHost
RawData. For details see UWIN-1821.

Host Routines

UWIN-1788 The SSH communications dialog box accepts an IPV6 address
for connecting to an IPV6 host. The dialog box has not changed.
Note that Teredo tunnelling is not supported, so all of the
network infrastructure must support IPV6.

Communications
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UWIN-1800 Query Builder supports NUMBER, TEXT, and FORMULA
qualifiers. The Run> Import File menu option has long
supported qualifiers that force the data to be treated in a
specific way regardless of the data or dictionary item. So
NUMBER(<dict_item>) and TEXT(<dict_item>) force values to be
stored in Excel as numbers and text respectively. For example,
some part numbers look like large numbers but should be
treated as text:

SORT PARTS BY PARTNO TEXT(PARTNO) PARTNAME PARTTYPE

In this release, UWIN-858 adds the ability for an Excel formula
to be stored in a U2 field and transferred to Excel where it will
perform calculations. The modifier is FORMULA(<dict_item>).
In previous releases, the Query Builder did not support these
qualifiers in the same way as Run> Import File. In this release,
they are supported consistently.

File Transfers

UWIN-1821 This release supports the Report Wizard on D3 per UWIN-1787.
The Report Wizard uses the GetFromHost RawData script
command to trap incoming data. As D3 sends CR/LF pairs
followed by a CHAR(0), we had to add an option to this script
command to allow CHAR(0) to be stripped out. Please see the
Client Scripting Reference for details.

Scripting

UWIN-1822 A new constant ThinClientUserName has been added.
This tells developers the user name entered when the thin
client logs in to the wIntegrate Server. It means the client
can be personalized for different users. The example script
Const.wis shows all of the constants. It has been updated to
show the new ThinClientUserName along with the other
constants.

Scripting

UWIN-1829 The Run > Import File or Export File dialog boxes can translate
characters during the import or export. This is often used to
handle differences between the delimiters in multi-valued data
and the file formats required on the PC. By default, translation
is only applied when importing or exporting to or from the ASCII
file format, though it can optionally be enabled or disabled for
all file formats. You can customize the translation settings by
clicking the Translation button. In this release, the Translation
button is disabled if the current settings in the dialog box
prevent translation. This will help prevent confusion on when
translation will take place.

File Transfers

UWIN-1841 The Run > Import File menu option imports multi-valued data
into various formats. One of these formats is Comma Quoted,
which is a comma-separated text file with all of the values in
quotations. This is different to the Comma Separated format,
which only has text in quotation marks and numbers are not
in quotation marks. When importing into Comma Quoted
format, if the last field in the line was null, then the CR LF was
omitted from the end of the line. This resulted in two lines being
incorrectly concatenated. This has been fixed.

File Transfers
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wIntegrate v6.3.4
Release Date: November 2013
These release notes provide information about enhancements and fixes in wIntegrate v6.3.4.

Enhancements and fixes in wIntegrate v6.3.4

The following issues were addressed in this release:

Issue
Number

Description Component

UWIN-435 Some of the older file formats have been removed from Run >
Import File or Export File and Run > Query Builder, as follows:

Run > Import File or Export File:

▪ Cardfile

▪ Ami Pro

▪ dBase

▪ Lotus 1-2-3 WKS format

Run > Query Builder:

▪ Ami Pro

▪ dBase

▪ Lotus 1-2-3 5.0

File Transfers

UWIN-540 The Learn script is used to capture your login process, and
then save it so you can log in automatically. You run it from
the Run > Script menu option. It is in the Program Files
\wIntegrate\wIntSys\Script folder. In this release, the
login information is stored more securely.

Scripting

UWIN-723 The object model supports setting individual cells in Excel.
This can be slow for large amounts of data. In this release, the
VarType function supports passing two-dimensional arrays to
Automation Servers such as Excel. Excel has a Value2 property,
which sets multiple cells faster that setting them individually.
To set this property, we have implemented support for two-
dimensional SafeArrays in wIntegrate scripting. They are
specified using the VarType function with the suffix "Array2". For
more details, see VarType in the Client Scripting Reference.

The host program demo WIN.OBDEMO has been modified to
demonstrate setting the Excel Value2 property, if the wIntegrate
version is 6.3.4 or greater. The host subroutine WIN.OBVTYPE
has been modified to work with multi-attributed values.

Scripting

UWIN-734 The Editor has a one-click option to transfer the program you
are working to the U2 host, and compile it. Any errors are shown
in the Editor. You can double-click an error to go directly to
that line of code. An unlimited number of errors can now be
displayed.

Other

UWIN-737 The Editor repositioned to the first page after Save To Host.
This has been fixed.

Other
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UWIN-739 In the Editor, Save To Host moved the cursor to end of
document. This did not happen every time, but once it did
happen, it happened every time. This has been fixed.

Other

UWIN-839 The Options  tab on the Setup > Preferences dialog box has a
check box option to trim trailing spaces when copying data from
the screen to clipboard. This dialog box now has an option to
trim trailing spaces when pasting data from the clipboard into
the screen.

Terminal Emulation

UWIN-849 The options for binary file transfer have been removed from
the Run menu. They were Kermit, Xmodem, Ymodem. and
Zmodem. They have been superseded by newer file transfer
formats and we believe they are no longer required. The
functionality is still in the product so they can be re-instated by
custom scripts if needed.

Setup and
Configuration

UWIN-1317 The Windows thin client did not pass certain control characters
to the U2 server. In our testing, they were Ctrl+C, Ctrl+X, Ctrl+Z,
and Ctrl+U. These characters are now passed to U2. The local
version and the Java thin client did not have this problem.

Thin Client
Deployment

UWIN-1380 The thin client deployment is a 3-tier model where the desktop
has a thin client acting as a screen-and-keyboard interface
to the wIntegrate Server on a central server. The user has
to log in to the thin client before seeing the U2 server. As a
service, the wIntegrate Server has no interface of its own. The
Administrator lets you set the various options. In this release,
the Administrator's Options dialog box has a new Client tab.
This tab lets you set and configure a new Timeout option (in
minutes). After the defined period of inactivity, the user will
have to log in to the wIntegrate Server again, regardless of the
connection status between the wIntegrate Server and the U2
host.

Thin Client
Deployment
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UWIN-1427 The program already supported multi-level properties for
ActiveX objects; now it also supports multi-level methods. This
script statement illustrates the issue. The relevant line that
should work is:

* x = Dialog_0.Explorer.Navigate
("http://localhost/MyGateway/Somesource/Gateway"

===============================
/* Dialog box Dialog_0

DialogBox Create Dialog_0 0,0,545,261
Caption "Dialog_0"
Style WS_CAPTION|WS_POPUP|WS_VISIBLE|WS_SYSMENU|
DS_MODALFRAME
AxControl Explorer, "Shell.Explorer",17,9,382,242
Pushbutton "Set value",Button_2,409,31,99,31
EditText Edit_4,410,12,91,12
Pushbutton "Get Value",Button_5,409,85,107,35
Pushbutton "Navigate",Button_6,425,158,83,52
ControlCommand Button_6,"Library '":ScriptFile:"'
;OnNavigate"
ControlCommand Button_5,"Library '":ScriptFile:"'
;OnGetValue"
ControlCommand Button_2,"Library '":ScriptFile:"'
;OnSetValue"

EndCreate

DialogBox Show Dialog_0
DialogBox Delete Dialog_0
EndScript

Sub OnNavigate()
x = Dialog_0.Explorer.Navigate("http://localhost/
MyGateway/Somesource/Gateway")
EndSub

Sub OnGetValue()
v1 = "id"
val = Dialog_0.Explorer.Document.getElementById
("customer_firstName")
Dialog_0.Edit_4.Text = val
EndSub

Sub OnSetValue()
Dialog_0.Explorer.Document.getElementById(
"customer_firstName").setAttributeDialog_0.Edit_4.Text)
EndSub
================================

Scripting

UWIN-1453 We have simplified and rationalized the licensing code. This
item is mentioned for information only; users should see no
difference in usage. This was required to enable any future
enhancements that might be required. The mechanism is
unchanged.

Installation
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UWIN-1474 In the Editor, if an item contains CHAR(255), any data after
that point is not saved to the host. This is perfectly reasonable
as CHAR(255) is the U2 Item Mark used to delimited items. It
follows that an item cannot contain its own delimiter. In this
release, if you try to save an item to U2 that contains CHAR(255),
a message is displayed, the save is abandoned, and nothing is
saved to U2.

File Transfers

UWIN-1478 Rocket's Aldon product family supports lifecycle management,
source control, and automated live deployment to the rigorous
standards required by today's auditing requirements. The Editor
has been enhanced to support the Aldon LM(e) source control
repository. Separately, TCL commands are also available for
UniData and UniVerse. As v6.3.4 is released, this new feature is
still under development.

In a nutshell, the Editor continues to let you edit, compile, and
run Basic programs. Now, if the appropriate LM(e) component
is installed on your PC, it will synchronize the U2 host with the
LM(e) repository. In addition to the classic default PROGram
type of item, the Editor can optionally read/write/synchronize
DATA and DICT items. These are supported so LM(e) can
automatically deploy these items to production environments.

A new Source Control  tab on the Tools > Preferences dialog
box lets you turn on this feature and set some options. This
tab is only operative if the integration component has been
installed.

Many users of the Editor will not use Aldon LM(e), and for these
users, the Editor's functionality will remain unchanged. For
more information about the U2 / Aldon LM(e) integration, please
email U2askus@rs.com.

Other

UWIN-1489 The Editor did not format all comments correctly. The Editor
recognized * as beginning a comment line but not ** or ! This
has been fixed.

Other

UWIN-1501 The Editor did not indent new lines. Since updating the editing
component in the Editor, a bug was introduced where the
cursor would always go to the beginning of the next line after
pressing CR. It now respects the indenting of the previous line,
and indents the new line to the same column position.

Other

mailto:U2askus@rs.com
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UWIN-1504 The following problems have been fixed in the Editor.

▪ The Format command did not recognize the syntax
LOCATE(THIS, THAT, POS) THEN.

▪ When two panes were shown, the Bookmark icons in the
toolbar did not respect Bookmarks in the lower pane.

▪ When saving a file to the U2 server, if the WIN.SERVER
failed to start for some reason, the Editor would wait until
the user pressed Cancel. It now times out and displays an
appropriate message.

▪ Users could see the classic message "An unnamed file
contains an incorrect path." This would appear if you
created a new item on the PC, then tried to overwrite an
existing item in U2, and clicked No at the Overwrite question.

▪ When editing a Basic program, clicking the Tools > Compile
and Run option caused a spurious "End" to be sent to the
host.

▪ When pressing Ctrl+F to search for a string, the program
assumed that the user wanted to search for the word where
the cursor was positioned. It now reuses the previous search
string unless some different text is selected.

Other

UWIN-1505 In the grid, when you click on a cell and start typing text, the
grid sends StartEditing and EndEditing events so the host
program can control the logic flow and receive entered data.
However, when clicking on a cell and pasting text from the
clipboard, these events were not sent. It was therefore not
possible for the host program to know whether the data in
the cell has changed. This was a regression in the new grid
introduced in 6.2.0. It has been fixed.

UWIN-1517 When data was imported from U2 into the .XLSX format, large
numbers could be corrupted by rounding. This has been fixed.

File Transfers

UWIN-1519 The user settings for wIntegrate are stored in the My
Documents\wIntegrate folder. The first time that you
run the program, this folder is created if it does not already
exist, and its content is populated from My Documents
\wIntegrate folders. (This is subject to custom modifications
specified in the winteg.wip file.) If the wIntegrate folder is
deleted from My Documents for some reason, the program is
now more resilient in re-creating it and its contents.

Other

UWIN-1520 The Options tab on Setup > Preferences has an Exit On Port
Close check box. This check box is disabled by default. It causes
the program to exit (as in File > Exit) when the connection to
the host computer is closed. When Exit On Port Close was
turned on, the program could crash if a dialog box was shown.
This might happen if you displayed the File > Open dialog box
without logging in. The host would eventually time out and
close the connection so the program would close. However, the
File > Open dialog box was not closed properly and caused the
crash. This has been fixed.

Other
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UWIN-1534 The Editor has a menu option to compile the current BASIC
program on the U2 host. After compiling the BASIC program,
the Editor could send an unnecessary END to the TCL/ECL
command prompt. This has been fixed.

Other

UWIN-1537 When we copy multiple lines of text from the screen, we
normally insert a CR/LF at the end of each line rather than copy
it as a single long piece of text. However, there are times when
you might want to copy text without the embedded new lines.
The Edit > Copy Special To dialog box now has a Text Only
radio button. When copying to the clipboard using this option,
spaces are trimmed, and CR/LFs are removed so multiple lines
are joined.

Terminal Emulation

UWIN-1545 The 6.3.2 release introduced support for data transfer to and
from the Excel .XLSX format. This would crash if the Translate
option was used to change CHAR(255), the Item Mark, to
another character. This has been fixed.

File Transfers

UWIN-1554 The Editor could crash when pasting from the
clipboard. The Editor crashed when the following
text was pasted into an empty script document:
"NýýýýýýýýýYýýýýýýýYýýýýýýýýýýýýNý2ýýýY" Where the ý
represents CHAR(253). This has been fixed.

Other

UWIN-1557 UWIN-734 describes an issue where the Editor could not handle
more than a screen of host compiler errors. That issue was fixed
by capturing compiler errors instead of displaying them on
screen. This required a new script command CaptureExec,
which uses WIN.SERVER to execute one or more statements
and capture the output as one or more variables. See the Client
Scripting Reference for details and an example.

There is a new set of host programs that accept a statement and
pass back the output. They are WIN.CEXEC.xx where xx is
the machine name, for example UV or UD. We have created the
WIN.CEXEC.xx routine for all supported machine types using
known syntax, but some of these have not been tested as we do
not have access to all these machines.

Scripting

UWIN-1658 Until this release, the Java thin client was built with Java 1.5. In
this release, the Java thin client is built with Java 7 (sometimes
known as 1.7). Users will need the Java 7 runtime environment
to be installed. As Java 7 was released in July 2011, we expect
users will have installed this version by now.

Thin Client
Deployment

UWIN-1693 If the user folder in My Documents was not set up properly, the
following message could appear: "Failed to open session file
Documents\wIntegrate\Session\Session1.wic". Subsequently,
running the Session Wizard and selecting the Save Settings
option crashed the program. This has been fixed.

Other

UWIN-1698 The file transfer in XML format would hang of the file length was
a multiple of 256 characters. This has been fixed.

File Transfers
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UWIN-1707 In the Setup > Application dialog box, on the Languages tab,
you can select Chinese as the language. The language takes
effect the next time you start the program. If you selected
Chinese in the 6.3.3 release, the next time you started the
program, a message was displayed in Chinese and the program
would hang. This has been fixed.

Setup and
Configuration

UWIN-1712 The terminal emulation has been enhanced to support the
"destructive" backspace key on all versions of AIX. To enable the
destructive backspace, go to the Setup > Terminal dialog box
and set the following:

▪ Select the Extension: destructive_bs

▪ Select the Backspace as Delete(127)

Terminal emulators display characters as instructed by the host.
So when you press a key, the host echoes it back. For example, if
you press "a," the letter does not appear immediately. Instead it
is sent to the host, which chooses to send the "a" back down the
line where it is received and displayed by the emulator.

Typically an emulator has no intelligence. So the backspace is
normally "non-destructive." This means that when you press
the backspace key (which Setup > Terminal lets you define as
CHAR(8) or CHAR(127)), the host sends back three characters:

▪ CursorLeft

▪ A single space character " "

▪ CursorLeft

For the user, this has the end result of wiping out the previous
character and moving the cursor back one. You can see all this
with the Edit > Record menu option using the Control codes
format.

AIX works differently. It uses a "destructive" backspace where
only the single backspace character is echoed back. The host
expects the emulator to perform the three steps of moving
the cursor left, displaying a space, then moving the cursor left
again.

In this release, the program supports the destructive backspace
as required by AIX.

In order to support the destructive backspace, we added
two new emulation commands: RemoveSequence
and DestructiveBackspace. RemoveSequence
removes a sequence previously added to the emulation.
In the destructive_bs extension, it is used to remove
the non-destructive backspace setting, so the
DestructiveBackspace instruction can be added in its
place.

Terminal Emulation
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UWIN-1714 WARNING: We strongly recommend that you avoid using
wBond32.dll for new development.

wBond32.dll allows interprocess communication. It was
originally written as the 16-bit wBond.dll and converted
to 32-bit for the 1998 release. Today, you would use OLE
Automation, which is much more comprehensive. In v6.3.2, we
removed this DLL from the installed files. A customer has asked
that we put it back.

Installation

UWIN-1717 The WIN.EDIT program supports PI/Open command-
line arguments. WIN.EDIT is one of the supplied U2 Basic
programs. It lets you invoke the Editor from the U2 TCL prompt
using the syntax:
WIN.EDIT filename itemname, for example, WIN.EDIT
WIN.PROGS WIN.DDE

In prior releases, this command line syntax was not supported
on PI/Open. We have now implemented support for PI/Open.

Host Routines

UWIN-1718 The CD menu, installer, splash screen, and Help > About dialog
box use a new blue constellation graphic.

Setup and
Configuration

UWIN-1722 All wIntegrate version 6.3.4 applications are certified to work
with Windows 8 on the Microsoft Surface Pro. This includes the
local install version in addition to the wIntegrate Server and thin
clients.

Other

UWIN-1725 When installing the product, you can select the Developer
Additions check box to install files of interest to developers.
For years, we have supplied sample applications that are
written in Visual Basic. In this release, we have rewritten
the sample Orders application in C# using .NET. You will
find this in Program Files\wIntegrate\Example
\CSharp\CSOrders. The folder contains an explanatory
document. The program uses sample files/data installed by
running the script inst_dem.wis in the Program Files
\wIntegrate\Host folder.

UWIN-1732 The Java client .JAR file can be used both as a plug-in on a
browser page, and as a stand-alone application with the same
look and feel as the regular Windows version. When run as a
stand-alone application, you can drag a border or corner to
cause the window to be resized, and an appropriate smaller/
larger font is automatically selected. This works the same way
in the Java client as the regular version. When resizing the
window, the Java client did not always snap to size correctly. It
could leave a small black border on the right side or bottom of
the window. This has been fixed.

Thin Client
Deployment

UWIN-1733 All wIntegrate version 6.3.4 applications are certified to work
with Windows 8.1 on the Microsoft Surface Pro. This includes the
local install version in addition to the wIntegrate Server and thin
clients.

Other

UWIN-1735 All wIntegrate version 6.3.4 applications are certified to work
with Windows 8. This includes the local install version in
addition to the wIntegrate Server and thin clients.

Other
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UWIN-1743 There was an error in the way the emulation tried to set the
function and edit keys or the qvt119 emulation. This has been
fixed.

Terminal Emulation

UWIN-1745 On some implementations of Windows, in the Run > FTP dialog
box, the two lower list boxes could overlap the buttons beneath
them. This has been fixed.

File Transfers

UWIN-1751 You can now use the Editor to edit dictionary and data items
in addition to programs. There are three new host programs to
explicitly open host items in the Editor with the required type of
DICT, DATA, or PROG. These new programs are:

▪ WIN.EDDICT filename itemname: Open the item from
the file dictionary

▪ WIN.EDDATA filename itemname: Open the item as a
data item

▪ WIN.EDPROG filename itemname: Open the file as a
program (same as WIN.EDIT)

Examples:

▪ WIN.EDDICT CONTACTS NAME

▪ WIN.EDDATA CONTACTS JOHN.SMITH

▪ WIN.EDPROG MYPROGS CONTACT.MAINTENANCE

For backward compatibility, WIN.EDIT continues to be
supported as before. Also, if you open a file from the Editor
using the File > Open From Host dialog box, you will now see a
drop-down menu letting you choose one of the three file types.
The file type determines available menu options, etc.

File types were introduced in the Editor as part of the
integration with the Rocket Aldon LM(e) product. They
determine how items are stored, deployed and possibly
compiled/cataloged during deployment to the live
environment. They are also useful to users of the Editor who do
not use LM(e).

Other

wIntegrate v6.3.3
Release Date: March 2013
These release notes provide information about enhancements and fixes in wIntegrate v6.3.3.

Enhancements and fixes in wIntegrate v6.3.3

The following issues were addressed in this release:

Issue
number

Description Component

UWIN-165 A user requested that the Editor should support lines of 32k. The
new editing component that is introduced in v6.3.2 does handle
lines of 32k in length.

Other
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UWIN-648 Some changes to the licensing have been made in this release:

▪ If the number of licensed users has been exceeded, no
further users will be allowed.

▪ We have enhanced the UserStat program, which shows users
on the network.

Other

UWIN-729 When host data is imported to an Excel file, a customer
requested that the column heading should be shown in full
regardless of the length that is specified in the dictionary item.
There are two places where data can be imported into Excel
files. They are Run > Import File and the Query Builder. The
newer Excel 2007 format .XLSX was introduced in the 6.3.2
release.

▪ In Run > Import File, importing to the new .XLSX format
in Normal mode expands the columns to accommodate the
full headings regardless of the length that is specified in the
dictionary item. This is different to the older .XLS format,
which the customer would have seen, where importing in
Normal mode truncates the heading to the length specified
in the dictionary item.

▪ In the Query Builder, importing to both .XLS and .XLSX
format in Normal mode results in the columns being
expanded to accommodate the full heading regardless of the
length that is specified in the dictionary item.

In both cases, Normal mode is set in the Advanced dialog box.

File Transfers

UWIN-850 A user reported that the program would close immediately after
starting up. This was caused by a combination of two factors:

▪ The user was starting a saved session whose host was not
available.

▪ The Options tab in Setup > Preferences had the Exit
Session On Port Close check box selected.

After trying and failing to connect to the host, the program
exited automatically. In this release, the OnPortClose function
is only executed if a successful connection to the host has been
made.

Communications
Terminal Emulation

UWIN-1146 A customer reported what looked like an error with data
transfer in UniVerse NLS mode. In fact this was not related to
NLS or multi-byte data, but a bug in the regular Run > Import
File code. The error happened when the data contained a
CHAR(128), which was incorrectly converted during an import,
but only in the RawData file transfer format. CHAR(128) is
handled differently to other characters because it is used for the
Euro symbol. The other file transfer formats convert CHAR(128)
to the Euro, but RawData does not, and this led to the issue. This
has been fixed.

File Transfers
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UWIN-1306 This is mentioned for information only; users will see no
difference in operation. Every build and release of the program
is checked with regression tests. A recorded user session
created with a working version of the program is played against
a newly developed version. The regression test tool then checks
that screen displays and file outputs are the same. The tool
that we have used for many years is no longer supported. We
are now using a new tool, and have re-created all of the tests
in the new tool. Many of the tests we use were supplied by
customers, particularly for terminal emulations, where it can
be impossible for the eye to detect incorrect displays. We are
happy to consider adding further tests from customers.

Other

UWIN-1329 When deploying thin clients, the wIntegrate Server runs as
a service. The service can be started and stopped by regular
Windows utilities. We also supply the Service Control Program,
which performs the same function. The Service Control Program
has a button to start the Administrator, which shows logged in
users and sets options for the wIntegrate Server.

The Administrator has an option to connect at startup. If this
option was turned off, and you started the Administrator from
the Service Control Program, the Connect At Startup option
would be turned on and saved that way.

In this release, starting the Administrator from the Service
Control Program will not change the value of the Connect At
Startup flag. This is achieved by a new /AutoConnect option as
a command line parameter for the Administrator.

Thin Client
Deployment

UWIN-1387 Object Model crashes with a null return dispatch pointer.
This concerns calling methods on the Microsoft Web Browser
Control document property. It was possible to crash the
program because the null return dispatch pointer was not
handled properly. Although this is a coding error in the
developer's script, the program should not crash under these
circumstances. It now shows the Script Monitor in the expected
way when this error condition occurs.

Scripting

UWIN-1398 The End User License Agreement is always shown during an
initial installation. In the future, it will be shown during an
upgrade when its terms have changed.

Installation

UWIN-1406 The following files are no longer installed because they are no
longer required.

▪ wIntDlg.exe - Dialog Designer, now incorporated into the
Editor

▪ wIntDlg.chm - Dialog Designer Help

▪ wIntDlg.CHS.dll - Dialog Designer, Chinese interface

▪ wIntegCHS.HLP - Chinese Help file. HLP files are no longer
supported

▪ vc8-re2001.dll  - was used by an old version of the
Editor

▪ SQL folder - an unused SQL Builder interface similar to
Query Builder

Installation
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UWIN-1409 Version 6.3.2 introduced support for importing and exporting
data in the Excel 2007 .XLSX format. This version of Excel
supports large files with up to 1,048,576 rows. To test v6.3.2, we
imported data to create .XLSX files of 2 MB and performance
was in line with data transfers to and from other formats.
However, when we tried importing 200,000 items, each with 20
attributes to create an .XLSX file of 21 MB, the transfer slowed
down during processing. In this release, performance is greatly
improved when creating .XLSX files larger than 20 MB.

File Transfers

UWIN-1410 While testing the v6.3.2 release on an early "RTM" version of
Windows 8, we saw that the Windows thin client did not display
the terminal screen properly when using the standard IBSfont.
Characters were either partly displayed, or "smeared" across
the display. This did not affect the local version, which worked
fine.

We cannot reproduce this issue on the shipping version of
Windows 8, so no work has been done. Please let us know if you
see any irregularities. Our standard font (IBSfont) is an old 16-
bit raster font. This type of font was superseded long ago by
TrueType fonts. We understand that support for raster fonts
will diminish in future versions of Microsoft Visual Studio. The
Consolas font that is bundled with Windows is a reasonable
substitute for IBSfont, especially if you want a full-screen
display on today's larger monitors.

Terminal Emulation

UWIN-1418 In some dialog boxes, there is an Open button that lets you
open saved settings. Examples are Run > Import File, the Query
Builder, and Setup > Keyboard. We have enhanced these dialog
boxes so that the corner can be dragged to show more files.
Also, a Show Columns check box lets you see the files in a
more detailed view with date and time saved. You can click the
column heading to sort by name or time/date.

Users of the Windows and Java thin clients will see that the
choice of folder has also been updated. By default, settings
for each thin client user are stored in a personal folder
on the server, which is specified in the dialog boxes as an
"!" (exclamation mark). Alternatively, the user can choose to
store settings on the local machine. The choice between these
two options was previously represented by radio buttons.
These radio buttons took some depth on the dialog box. In this
release, just the active folder is shown. The user can choose the
alternative from a drop-down menu, or click a button to browse
for a different folder.

Setup and
Configuration

UWIN-1423 In the Editor, when using Edit > Format All to format a script,
some object properties were not correctly indented. This has
been fixed.

Other



wIntegrate v6.3.3

49

Issue
number

Description Component

UWIN-1424 One of the characters in the supplied font IBSfont was not
displayed correctly. This could be reproduced by running the
ChrSet2.wis script in the Program Files\wIntegrate
\Example\Script folder. With all of the characters displayed
on screen, if the corner of the screen was dragged to resize
the window, character 149 left "droppings" on the screen.
The similar script ChrSet.wis also displays characters, but
displayed all the characters properly. This was a strange issue
with the display of a single character. It has been fixed.

Terminal Emulation

UWIN-1426 When deploying thin clients, the wIntegrate Server runs as a
service and has no interface of its own. The Administrator is the
interface for the various options and also shows logged in users.
In the Administrator's Options, Security tab, you can associate
functionality with groups of users authenticated by Windows
Active Directory. One of these groups is the Monitor End Group,
who can end a user session from the wIntegrate Monitor. There
was a bug where any changes to the Monitor End Group setting
in the Administrator were not saved or recalled properly. This
has been fixed.

Thin Client
Deployment

UWIN-1439 This case affects only thin client deployment. If a script takes
a long time to execute, perhaps because it is stuck in a loop
due to a programming error, the thin client now responds to
user input such as clicking the Exit button to close the session.
This response happens after a timeout has been triggered. The
default timeout value is 10 minutes (600,000 milliseconds). In
the unlikely event that value this needs to be changed, it can
be done with a new Script Loop Timeout setting. Please see the
wIntegrate Administration Guide for more information.

Thin Client
Deployment

UWIN-1445 All wIntegrate version 6.3.3 applications are certified to work
with Windows Server 2012. This includes the local install version
in addition to the wIntegrate Server and thin clients.

Installation

UWIN-1452 The program would crash when attempting to display a tooltip
longer than 80 characters. This applied to tooltips on any
regular control in the dialog box, such as buttons. text boxes,
and check boxes. However, the crash happened before the
tooltip was displayed so it seemed very random. This bug has
always been present in the product.

The workaround in v6.3.2 and earlier versions is to reduce
the length of tooltips to 80 characters or less. This is now
fixed in v6.3.3. Tooltips longer than 80 characters are now
truncated to 80 characters. The issue did not occur in very
early versions. Note that the crash was reported as happening
in comctl32.dll, one of the components of the Microsoft
Foundation Classes (MFC) that the product uses. Initially
this led us to suspect, incorrectly, an issue with the MFC
installation. In the past, we have seen issues with MFC "side-
by-side assemblies," which were usually fixed by uninstalling
and reinstalling the product, or by downloading and installing
the appropriate Microsoft Visual C++ Redistributable Package.
However, in this case, the MFC installation was not at fault.

Other
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UWIN-1463 In the Java client, clicking a menu option twice showed the
Script Monitor. This applies only to thin client deployment,
where dialog boxes are stored on the wIntegrate Server and
transferred to the thin client on request. Further, it only applies
to the Java thin client.

When the user clicks a menu option or a button to display a
dialog box, it can take a little while for the dialog box to be
transferred from the server and appear. This is especially true
on slow networks, or if the dialog box has not been shown
before and so has not been cached on the wIntegrate Server.
If the user gets impatient while waiting for the dialog box to
appear and clicks the menu option or button again, the server
tried to show the same dialog box twice. This resulted in the
script error "The dialog box has already been shown," which
is disconcerting for users. The Windows thin client does not
have this issue because it automatically pauses until it gets a
response. We cannot do the same in the Java client because it
works differently. Two things have been changed:

▪ If a menu option is being executed, the Java client will not
run another menu option until the first one has finished.

▪ If the user clicks a button a dialog box to show another
dialog box, for example, File > Open in the Query Builder,
then the button is disabled until the script triggered by the
first script has completed.

Thin Client
Deployment

UWIN-1464 Small integers in the range -255 to -128, and possibly -65535
to -32768 did not get sent by the wIntegrate Server to the thin
clients correctly. This applied to both the Windows and Java
thin clients. This bug could apply to anything that tried to send
an internal message to the client that included numbers in the
given range. This has been fixed.

Thin Client
Deployment

UWIN-1466 The DialogBox Panel command now supports a divider
that splits the dialog box into different areas. It is used to
automatically position controls when the dialog box resized
by dragging the border. We introduced this new parameter
to address UWIN-1418 to show more information in the File
> Open dialog boxes. To see an example, click the Open
button on the Run > Import File dialog box. For syntax, see
the DialogBox Panel script command in the Client Scripting
Reference Manual.

Scripting

UWIN-1472 In the grid, if you click a cell and type text, the grid sends
StartEditing and EndEditing events so the host program can
control the logic flow and receive entered data. However,
when clicking a cell and pasting text from the clipboard, these
events were not sent. It was therefore not possible for the host
program to know whether the data in the cell has changed. This
was a regression in the new grid that was introduced in 6.2.0. It
has been fixed.

Scripting

wIntegrate v6.3.2
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Release Date: October 2012
These release notes provide information about enhancements and fixes in wIntegrate v6.3.2

Enhancements and fixes in wIntegrate v6.3.2

The following issues were addressed in this release:

Issue
Number

Description Component

UWIN-62 The Editor uses a third-party component for the main editing
window. This handles the text entry, syntax coloring, and so on.
In this release, the Editor has been changed to use the Scintilla
component, which is supported with Visual Studio 2010. There
may be minor, inconsequential differences from the previous
version. We believe that all functionality has been reinstated,
but please let us know whether you see any discrepancies.

Other

UWIN-182 The Run > Import File and Run > Export File menu options
create Excel files directly. These options now support the
.XLSX format native to Excel 2007 and later. Spreadsheets in
the .XLSX format support 1,048,576 rows where Excel 2003 was
limited to only 65,536 rows. eCase 9941 in version 6.1.3 covered
the need to update the version of the files created from Excel
4 format to Excel 2003 format. The Excel 2003 .XLS format is
still supported for backward-compatibility. This issue does not
affect the Query Builder, which imports data to a text file then
uses OLE to tell the user's installed version of Excel to save the
file in its own native format.

File Transfers

UWIN-184 The Query Builder now supports the Excel 2007 .XLSX file
format. It is described in the dialog box as Excel 2007. The
earlier Excel .XLS format is still supported as a separate
option. It is now described in the dialog box as Excel 2003. Two
technical notes:

▪ The new Excel 2007 .XLSX format creates the file directly.
The Excel 2003 .XLS option continues to create the file by
importing the data as a text file in tab-separated format,
which is opened and saved as .XLS by your installed version
of Excel.

▪ In previous releases, there was a single Excel menu option,
but this single word no longer exists as an option. If you have
saved queries with the Excel format, they will be converted
at run time to Excel 2003, which is the new equivalent.

File Transfers

UWIN-724 The host subroutine WIN.DBSHOW displays a dialog box
on the PC. In this release, the number of messages that are
exchanged between the host and PC has been reduced. This
gives a performance improvement of at least 30% and more on
slower networks.

Host Routines

UWIN-738 The Editor could stop saving changes to the host even though
the changes appeared to be committed to the local copy. This
was reported by a user, but we were never able to reproduce
the issue in-house. We have made substantial changes to the
Editor on 6.3.0 (integrating the Dialog Designer) and now in 6.3.2
we have changed the editor component. We believe this issue
should be fixed by these changes.

Other
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UWIN-838 The host programs are installed using the inst_pgm.wis
script. It creates a file WIN.PROGS, transfers the wIntegrate
programs into this file, and then compiles and catalogs them.
If WIN.PROGS already existed and you ran inst_pgm.wis, a
spurious file that is named ED WIN.PROGS MACHINE.TYPE
was created. The programs were installed to WIN.PROGS
correctly but this file was left in place. This has been fixed.

Host Routines

UWIN-863 Since the 6.3.0 release, we have signed the executable .EXE
files as coming from Rocket Software (UWIN-801). Signing is
increasingly used to help with security with Windows and virus
checkers. In this release, we sign all executable .EXE, .OCX
and .DLL files.

Other

UWIN-866 A new grid was introduced in the 6.2.0 release. In the old grid,
when focus was set to a cell that was not visible, the grid would
immediately scroll to the cell, and show the text cursor in that
cell. However, the new grid did not scroll to a non-visible cell
until the user began to enter data. This has been fixed. We have
also implemented the same automatic scrolling when a column
or row is made active and not currently visible.

Scripting

UWIN-873 This case is mentioned for information only; users should see
no difference in operation. Before this release, the applications
were compiled with Microsoft Visual Studio 2008. (eCase 38813
in version 6.1.3.) In this release, the compiler has been upgraded
to Visual Studio 2010. Other third-party controls included
with the product have been upgraded as necessary. Following
usual good practice, we amended the code to remove any new
warning messages. Developers and Support personnel should
be aware that the application now uses Microsoft Foundation
Classes (MFC) version 10.0. MFC provides the underlying
functionality for the product. wIntegrate automatically installs
into system folders any required MFC files that have not already
been installed by other applications. Support personnel
occasionally have issues when new versions of MFC are used.
Some MFC issues with "side-by-side assemblies" might be fixed
by downloading and installing the Microsoft Visual C++ 2010
Redistributable Package.

Other

UWIN-1307 The Editor would crash if the item being edited had a single line
with the three characters "ARP". This was fixed by the other
changes we made to the Editor in this release.

Other

UWIN-1316 The Grid Font property was not selecting the correct font for all
sizes. It was setting the font one size smaller than specified for
some font sizes. This was caused by a rounding difference. This
is fixed.

Scripting

UWIN-1334 In the WIN.DBSET host program in WIN.PROGS, line 58 was:

LEN.LEFT = LEN.LEFT - C;

The trailing semi-colon has been removed. The semi-colon is a
valid statement delimiter, but on some platforms, the compiler
objects if it is not followed by a statement.

Host Routines
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UWIN-1350
UWIN-1363

The supplied host subroutine WIN.FTTOASC converts data
from the 7-bit file transfer format to ASCII. In v6.3.0, a regression
error was introduced where this routine could truncate the
converted data. This error happened as a consequence of
UWIN-818, where the host routines were modified to support
unlimited amounts of data. The WIN.FTTOASC routine is called
by several of the supplied programs. Any of these programs
might result in errors. The programs are:

▪ WIN.PCREAD

▪ WIN.FTPREAD

▪ WIN.GETDATA

▪ WIN.PCREADAL

This has been fixed.

Host Routines

UWIN-1353 On a fresh machine that has never had a wIntegrate license
before, when the licensing dialog box first came up, it defaulted
to describing the "10 day evaluation license" with a date 60
days from today. The date that is shown should be 10 days from
today. In 6.2.0, we changed the evaluation period of the regular
CD-based version from 60 days to 10 days. We forgot to change
the calculation for this display-only field. The incorrect date was
only shown the first time that the dialog box was displayed on
a fresh machine. It was not used in any licensing calculations. It
now shows the date as 10 days from today.

Installation

UWIN-1355 Links to relevant web sites are shown in two places: the More
Information dialog box on the Help menu and the Web Sites
page in the readme that is shipped with the product. Two
changes were made to keep the links up-to-date:

▪ The link to Support is now www.rocketsoftware.com/
support. It was the U2 TechConnect knowledgebase, which
has now been merged into the Rocket Knowledgebase.

▪ In the More Information dialog box, the link to the manuals
is now www.rocketsoftware.com/u2/resources/technical-
resources.

Other

UWIN-1359 All wIntegrate version 6.3.2 applications are certified to work
with Windows 8. This includes the local install version in
addition to the wIntegrate Server and thin clients.

Other

UWIN-1371 When using the grid property TrackHeight, the grid could show
the top left cell as highlighted/selected until another cell was
selected. This was a regression in 6.2.x and onwards compared
with earlier versions. It has been fixed.

Scripting

UWIN-1376 This is mentioned for information only; users will see no
difference in operation. An old executable wBond32.dll
no longer needs to be shipped with the product. It has been
removed from the installation. wBond32.dll was created
some years ago for backward-compatibility with a 16-bit DLL
used by Visual Basic. All this was superseded long ago by
developments in 32-bit Windows and Visual Basic.

Installation

www.rocketsoftware.com/support
www.rocketsoftware.com/support
www.rocketsoftware.com/u2/resources/technical-resources
www.rocketsoftware.com/u2/resources/technical-resources
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UWIN-1401 A ComboBox in a cell was left active when the cell was disabled.
This was a regression in 6.2.x and onwards compared with
earlier versions. It has been fixed.

Scripting

UWIN-1402 In the grid, pressing the Esc key did not generate a Cancel event.
The Esc key was not recognized in the grid. As a result, when
using an application created for use with 4.2, pressing Esc could
cause the application to hang. This was a regression in 6.2.x and
onwards compared with earlier versions. It has been fixed.

Scripting

UWIN-1408 When dual monitors were used, and the grid was displayed on
the left-hand monitor, a drop-down control would appear on
the right-hand monitor. This has been fixed.

Scripting

wIntegrate v6.3.1
Release Date: July 2012
These release notes provide information about enhancements and fixes in wIntegrate v6.3.1

Enhancements and fixes in wIntegrate v6.3.1

The following issues were addressed in this release:
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UWIN-1325 A customer reported the following issues when using Japanese
Katakana characters with a UniData server:

▪ Screens could be distorted with terminal emulation
sequences visible on the screen.
This happened because some of the multi-byte characters
were being treated as separate characters and not as a
multi-byte pair. This confused the terminal emulation
processing. The cause was a timing issue. Characters
received as part of a multi-byte sequence were sometimes
not joined up correctly when the constituent bytes were
received in different network packets. Perhaps this issue
in wIntegrate was exposed by the way UniData does its
communications.

▪ When entering Katakana characters, a window
automatically appears to let the user choose the required
characters from a displayed list of options. wIntegrate
required two extra keystrokes to choose the required
characters compared with other Windows programs.
When the user moves up and down in the window to choose
the required characters, the currently highlighted string
is displayed on screen. However, when a short string of
characters was displayed, the trailing end of long strings
was left visible. Full-width and half-width characters were
affected.

These issues are now fixed. If you want to use Japanese
Katakana characters on a non-Japanese Windows system, you
must set the Host Encoding field in Setup > Terminal to 20932.
The Host Encoding field cannot be edited manually, and must
be set programmatically. You can set the Host Encoding field
with the following script statement:

Set HostEncoding = 20932

Alternatively, you can set Host Encoding in a host BASIC
program as follows:

PRINT CHAR(27) : CHAR(1) : "Set HostEncoding = 20932" : CHAR(13) :

Communications

wIntegrate v6.3.0
Release Date: December 2011
These release notes provide information about enhancements and fixes in wIntegrate v6.3.0

Enhancements and fixes in wIntegrate v6.3.0

The following issues were addressed in this release:
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UWIN-176 The application icons have been updated. To meet current
Windows standards, each icon supports various color depths
and sizes, up to 256 x2 56 in 32-bit color (the "Extra Large Icon"
size).

Installation

UWIN-597 When the GUI is controlled by host Basic programs, supplied
subroutines such as WIN.DBGET and WIN.DBEDGET accept
input from the client. When the user enters data in a field and
presses the Tab key, the host application will normally validate
the entered data; then, if the validation is OK, it will set the
focus to the next field, and set the default value. Although this
is done very quickly, the messages can erase user input for the
next field if the user is typing very quickly.

Three new programs, WIN.DBGET2, WIN.DBFETCH2,
and WIN.DBPOST2, handle faster user input. They are
updated equivalents of the original programs. There is also
WIN.DBEDGET2, an updated version of WIN.DBEDGET,
which gets data from multi-value edit controls. (For backward-
compatibility reasons, we cannot make significant changes to
existing programs so we created new ones.)

The above programs are installed by the regular host program
installer when you select the Host API check box. A new demo
program WIN.CUSTMD3 shows how these programs are used.
It is on the WIN.DEMOMENU menu. To install WIN.CUSTMD3
and WIN.DEMOMENU, run the demo inst_dem.wis install
script in the Program Files\wIntegrate\Host folder.

Host Routines

UWIN-707 The copyright statements in the host Basic programs have been
updated.

Host Routines

UWIN-723 The Setup > Colors dialog box has an Advanced tab. Users will
rarely need to use this option. The layout of the options under
the Advanced button has been improved. The group box of
controls with the Bold/Reverse/Flash settings has been moved
up. It now has the caption Selected Attribute.

Scripting

UWIN-728 SSH communications could hang when a lot of data came down
the line from the server. The screen would freeze. After a minute
or more, the session would sometimes free up and become
usable again. We were able to reproduce this and fix it.

Terminal Emulation

UWIN-759 A new grid control was introduced with the 6.2.0 release. The
SortColOnDblClick function did not always work. This has been
fixed.

Scripting

UWIN-761 Users who enter times and dates in dialog boxes can now use
the Tab and Shift + Tab keys to move between the elements of
the date or time (for example, the month, day, and year; hours,
minutes, and seconds). Previously, you had to use the Right
arrow and Left arrow keys to move between these elements.
This was inconvenient because it meant switching between the
Tab and Arrow keys.

Scripting

UWIN-775 The Copy menu appears when you right-click the terminal
screen. It has always had numerous options to copy to different
formats and destinations, but not to or from the clipboard as
text. We have now added two new options to the Copy menu
that support simple copy and paste of text.

Setup and
Configuration
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UWIN-776 The wIntegrate Administrator application wIntAdm.exe is
installed with the wIntegrate Server as part of the thin client
deployment. Symantec Norton Antivirus mistakenly found a
"Suspicious DLoader" virus in versions 6.2.x of wIntAdm.exe
and quarantined it. The wIntegrate Administrator is written
entirely by Rocket Software developers. It is a relatively
simple program with no external code or binaries. The code
is essentially unchanged from the earlier releases in which
Symantec did not find a virus. We are not aware of any other
antivirus applications reporting a virus in wIntAdm.exe.

We submitted this false positive to Symantec. They have
removed this detection from their virus definitions. We acquired
a copy of Norton Internet Security and were able to verify
that their virus definitions now allow wIntAdm.exe to work
properly. We had the same issue in early 2010, mentioned in the
6.2.0 release notes under eCase 41429 / UWIN-69. We reported
that false positive to Symantec, who removed the detection at
that time, also. However, in the 6.2.0 release, the publisher of
wIntAdm.exe changed to Rocket Software so presumably the
2010 white-listing was no longer effective. See also UWIN-801
below.

Other

UWIN-779 In the Setup > Terminal dialog box, the Smart Input
Conversion check box lets you specify that Unicode characters
should be converted to equivalents that can be pasted into
the emulation screen. The smart quotes “ and ” copied from
Microsoft Word are converted to ". The conversions are
performed according to a table in the InputMap.txt file in
the Program Files\wIntegrate folder. In this release, the
single quote characters ‘ and ’ are converted to '.

Terminal Emulation

UWIN-786 A new grid control was introduced with the 6.2.0 release. In the
previous grid, it was possible for the developer to change the
background color of the cell while the user was in the process
of entering data into the cell. In the new grid, changing the
background color took effect only on entering or leaving the
cell. In this release, changing the background color also takes
effect while the user is entering data.

Scripting
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UWIN-787 A new grid control was introduced in the 6.2.0 release. Setting
properties in the new grid with data was noticeably slower
than the previous grid when the grid had thousands of rows.
A customer noticed this when using the SetRangeFont
command. In this release, the time taken to set properties has
been substantially reduced.

With earlier versions of 6.2.x, there are two workarounds to
improve performance when setting properties for a large
numbers of rows:

▪ Set the property for the entire grid instead of a range. This
was not possible with the old grid. It can be done before or
after the grid is populated with data and is much faster than
the SetRange command.

▪ Use the new capability introduced in v6.2.2 to set the
properties for an entire column - see UWIN-752 in version
6.2.2 release notes. The property should be set before the
cells are populated. The command also works after the cells
are populated but will not be faster.

Scripting

UWIN-788 In a U2 Basic program, the PRINT @(0) statement positions the
cursor at the beginning of the current line. The ADDS Viewpoint
terminal emulation sends the sequence \016\128, which was
not being interpreted properly as wIntegrate was expecting
\016\000. This issue has always been present. To correct this,
a new CursorCode "B" has been created and used in the ADDS
Viewpoint emulation. This is the same as CursorCode "A" except
that an X coordinate of CHAR(128) is treated as column 0. The
wIntegrate terminal emulation definitions are text files with the
.WIT extension so a workaround was possible. The following
line would intercept the relevant escape sequence and move
the cursor with a script statement:

TerminalCommand = "\016\128", "Display MoveX 0"

Terminal Emulation
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UWIN-789 The Run > Import File menu option lets you import host data
into Excel 2003 format. (We intentionally support older file
formats because these can be used by the greatest number of
users.) In Excel 2003, the .XLS file format supports a maximum
of 65,536 rows. In previous releases, Run > Import File let you
create .XLS files with more than 65,536 rows. However, Excel
opened these files with an error, warned that data would be
lost, and displayed only 65,536 rows.

In this release, when importing data with the Run > Import
File menu option, the transfer stops with an error message
after 65,536 rows have been written to the .XLS file. The newly
created file is unreadable, but it is left on the hard disk as this is
consistent with other failure processes.

If you have optionally chosen to SELECT items before the
transfer starts, and the result is more than 65,536, then a
warning message is displayed. However, the transfer is allowed
to proceed because you might have Translation parameters in
place that reduce the number of rows to fewer than the number
of host items.

This does not apply to the Query Builder imports to Excel. This
creates a text file with the .TSV extension (Tab-Separated
Values), and uses your installed copy of Excel to open the .TSV
file and save it in the native Excel format. For most people, this
will be the .XLSX format in Office 2007/2010, which supports
1,048,576 rows.

File Transfers

UWIN-790 Version 3 supported a single "icon bar" and a single "base
bar" (under the 80x24 emulation screen). Version 4 and later use
different scripting syntax and support multiple toolbars above
and below the emulation screen. The difference in syntax meant
that users could experience script errors when combining old
and new toolbars due to the way a library was loaded. The
toolbar scripts have been changed to load the library at a
different point in the logic. This allows old and new icon/tool
bars to work together without modification.

Setup and
Configuration

UWIN-794 The General icon bar has buttons to increase and decrease the
font size. If the SnapToSize check box in Setup Application is
selected, the resulting resized window should be automatically
resized according to the new font size, and trim off any borders.
In the Windows thin client, clicking the Font Larger button
resulted in a black border at the right and left of the terminal
window. This did not affect the local version, which worked fine.

The code that calculates the font size and resizes the window
was different in the thin client and the local version. Something
was overlooked when we went through the process of sharing
code between the two versions. Resizing the windows in the
Windows thin client now works the same as the local version.

Terminal Emulation
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UWIN-795 The Edit > Copy Special To dialog box lets you choose a format
and destination for the Edit > Copy Special menu option. For
convenience, this dialog box also has a Copy Now button, which
does the same as the Edit > Copy Special menu option. The
Copy Now button was always grayed out and never available to
the user. This has been fixed.

Setup and
Configuration

UWIN-796 A new grid was introduced with the 6.2.0 release. It had a bug
where a crash would occur if the number of rows in the grid was
reduced. This has been fixed.

Scripting

UWIN-797 A new grid control was introduced with the 6.2.0 release. In
the old grid, clicking a cell fired two events - the ButtonClick
and the CellClick. In the new grid, clicking a cell fired only the
ButtonClick event. The grid has been changed so that clicking a
cell fires both events.

Scripting

UWIN-798 A new grid control was introduced with the 6.2.0 release. The
SetCellValue method did not work the same way. In the old grid,
when a cell had been updated by the user and still had focus,
the SetCellValue method would update the cell. In the new grid,
the SetCellValue method did not update the cell. The new grid
has been changed so the SetCellValue method can update the
cell while it still has focus.

Scripting

UWIN-799 The Editor and the Dialog Designer have a Help icon on the far
right of the toolbar. It is a question mark with a pointing arrow.
The user can click this icon, and then click a menu option such
as File > Open to see the context-sensitive help for that menu
option. This feature had stopped working in the Dialog Designer
and Editor. Instead of launching the Help topic, it displayed a
message "Failed to launch help." This has been fixed.

Setup and
Configuration

UWIN-800 The Setup > Terminal dialog box has a Smart Input
Conversion check box. When selected, any entered characters
are converted according to the conversion table in the
inputmap.txt file. For example, Word's smart quotes are
converted to simple quotes. The Smart Input Conversion check
box was not being saved properly in the thin clients. It was
always shown as turned off. This has been fixed.

Setup and
Configuration

UWIN-801 The wIntegrate Administrator is installed with the wIntegrate
Server as part of the thin client deployment. It is the controlling
interface for the wIntegrate Server, which has no native
interface because it runs as a service. Symantec Norton
Antivirus incorrectly reports the wIntegrate Administrator
(wIntAdm.exe) as a Suspicious DLoader virus and quarantines
it. This has created disproportionate problems for some
customers. See UWIN-776 above. To reduce the risk of an
anti-virus program detecting another virus, we now sign the
executable .EXE files as coming from Rocket Software.

Other

UWIN-803 A new grid was introduced with the 6.2.0 release. The
ScrollToCell method worked slightly differently. The scrolling in
the new grid has now been changed. This means that if the cell
is already displayed, then the grid does not scroll at all. if the
grid has to scroll because the specified cell is not shown, then
the grid will scroll vertically. If the vertical scrolling does enough
to show the cell, then the grid will not scroll horizontally.

Scripting
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UWIN-804 The syntax of the PDF BeginDocument command allows an
optional error parameter that should return the occurrence of
an error and its type:

PDF BeginDocument filename, [err_var]

The error parameter was not working. It did not trap errors if the
file could not be created, so the script was unable to react to the
error condition. This has been fixed.

Scripting

UWIN-806 Scripting supports the ability to copy from the terminal screen
to clipboard. A new command, DialogBox CopyTo, copies
dialog boxes and their data contents. The syntax is:

DialogBox CopyTo dlg_name, destination,
[file_name], [scale]

Available destinations are Clipboard, Printer, and File (as a
bitmap with a user-specified file name). When the destination
is Printer, the bitmap can be scaled. See the Client Scripting
Reference for details.

When sending the bitmap to the printer, the orientation can be
set to portrait/landscape by using the PrinterOrientation global
variable, as seen in the File > Printer Setup dialog box.

There are some limitations due to the way this works. On the
local version and the Windows thin client, some third-party
custom controls may not be shown. Also, some Windows
themes may not show all controls On the Java thin client, none
of the dialog box furniture is shown, such as Close buttons.

Scripting

UWIN-807 Attempting to export an Excel spreadsheet to the U2 server
could give a fatal error "Unable to read file from host." The
error message was misleading because the file had been read
successfully. The problem was that wIntegrate could not
decipher the data. The wIntegrate code was failing to take into
account a change in encoding for a single string that spanned
two of Excel's internal record blocks. This has been fixed.

File Transfers

UWIN-809 The technical icon bar has a new icon that prints the current
screen along with the current time/date. You can turn on
the technical toolbar by right-clicking the icon bar area and
selecting bar_tech. This runs the bar_tech.wis script in
the Program Files\wIntegrate\wIntSys\IconBar
folder.

This toolbar now has a new icon with the tooltip "Copy Screen
to printer with customizable text." This script creates a
temporary PDF file with the current character screen inside a
border, adds some text showing the date and time the file was
created, and sends the page to the printer.

Scripting
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UWIN-810 This is a significant new feature, simplifying the creation of host
Basic programs that drive dialog boxes. The Dialog Designer,
which paints dialog boxes, has been integrated into the Editor.
Previously, the Dialog Designer and Editor were separate
applications and could be used to edit the same script at the
same time, which was poor practice.

In this release, the Editor shows the script and the Dialog
simultaneously. As a change is made in one window, it is
automatically reflected in the other. The dialog box view is not
displayed automatically – you click the Window > New Dialog
View menu option to display the dialog box.

The Dialog Designer is still installed with this release, but it
will be removed from future releases. A tutorial is supplied
describing how to use this new feature. Please see the
document Editor_Tutorial.doc in the Program Files
\wIntegrate\Host folder.

Host Routines

UWIN-811 The host routine WIN.DBSETPRP sets properties of controls
in dialog boxes, including grids. Previously, WIN.DBSETPRP
was not able to set variables larger than around 100 K. This
restriction has now been removed. The routine will now handle
data of any size. Note that this issue was caused by the way the
host program transferred the data to the PC. The grid itself did
not have this restriction.

Host Routines

UWIN-813 The PDF BeginDocument command has an optional error
variable. If the developer chooses to use this, then any error
should be returned to the variable. If the error variable is
not used, then the error will be shown in the Script Monitor.
However, when the developer chose to use the error variable, it
was not being set when an error occurred. All errors resulted in
the Script Monitor and the error variable was ignored. This has
been fixed.

Scripting

UWIN-814 The SetRowHeight method sets the height of rows in the grid. It
failed to set the height of the last row. This has been fixed. It was
a simple error in the code.

Scripting

UWIN-815 The PDF TableFormat command is used to set the font
for the title row of the table. The height of the row must
be set before it can set the font, otherwise the headings
disappear. If the height has already been set with the PDF
TableSettings command, then PDF TableFormat works
fine. In any case, we have modified the PDF TableFormat
command to calculate the row height if this has not already
been done with PDF TableSettings.

Scripting
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UWIN-816
UWIN-817

Scripting lets you created PDF files. A customer reported
an issue when using the PDF BeginHeader command.
Please note that the PDF DocumentSettings command
should be used before the PDF BeginDocument command;
otherwise some settings may not take effect. The PDF
DocumentSettings command has to set the header height
before the PDF BeginDocument starts the document,
otherwise it is ignored. The document settings apply from then
on, so once they have been set, all future documents will pick
them up.

Scripting
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UWIN-818 A separate issue, UWIN-811, concerns restrictions on the size
of data supported by the WIN.DBSETPRP routine. Having
fixed this issue, we examined other host routines that pass
variables from the host to the desktop. We discovered that most
routines could not transfer more than 100k of data in a single
variable. We have now removed any limits from the following 35
subroutines:

▪ WIN.ASSIGN

▪ WIN.DBEDGET

▪ WIN.DBEDSET

▪ WIN.DBGET

▪ WIN.DBGET2

▪ WIN.DBGETM

▪ WIN.DBGETPRP

▪ WIN.DBINIPRP

▪ WIN.DBLSTGET

▪ WIN.DBMETHOD

▪ WIN.DBSET

▪ WIN.EVAL

▪ WIN.FSCRIPT

▪ WIN.FTPWR.UN

▪ WIN.FTPWRITE

▪ WIN.FTTOA.UN

▪ WIN.FTTOASC

▪ WIN.GETLIST

▪ WIN.GETVAL

▪ WIN.MLADDR

▪ WIN.MLDELETE

▪ WIN.MLFIND

▪ WIN.MLNEXT

▪ WIN.MLREAD

▪ WIN.MLSEND

▪ WIN.OBGETPRP

▪ WIN.OBMETHOD

▪ WIN.OBSETPRP

▪ WIN.PCRAL.UN

▪ WIN.PCREADAL

▪ WIN.PCWRI.UN

▪ WIN.PCWRITE

▪ WIN.RSEXEC

▪ WIN.SETLIST

▪ WIN.SETVAL

Host Routines



wIntegrate v6.3.0

65

Issue
Number

Description Component

UWIN-819 The existing VT220 emulation defines 8-bit characters (above
character 127) as emulation commands. This is a correct
optional setting in the VT emulation, but it can conflict with
accented characters in non-English languages. Setup >
Terminal now shows a new emulation option of VT220-7bit.
This is identical to VT220 but without the 8-bit characters.
Adding this new emulation was the most backward-compatible
way to support the 7-bit VT220 emulation.

Terminal Emulation

UWIN-821 A new grid was introduced with the 6.2.0 release. The
PushButton was handled differently. In the new grid, double-
clicking the PushButton turned the cell into an edit-text box,
and let the user change the text. This was incorrect and has
been fixed.

Scripting

UWIN-822 A new grid was introduced with the 6.2.0 release. There was a
random bug where the font might not be set correctly or might
change, perhaps when using the Grid ClearRange method. This
was caused by code that reused font memory after a font had
been released. It has been fixed.

Scripting

UWIN-826 If you ran a subroutine that has been cached from a script
library, and another script unloaded the cached library while
the subroutine was running, the script monitor appeared with
an error such as "invalid start of statement." Somehow it did
not crash the program. It is now possible to unload a cached
script while it is running, and this will not cause any problems.
This has been fixed.

Scripting

UWIN-827 Strings and possibly other types that are passed to wIntegrate
in COM variants can use a BY_REF copy of the value passed
in VB.NET. This is a reference to the variable rather than the
value. wIntegrate did not expect this, so in most cases, it either
ignored the value passed or reported an error. We checked all of
the automation methods. The following ones could have caused
a problem in this area and had to be changed:

▪ Session (CSessionCtrl) ShowDialog

▪ Session (CSessionCtrl) InvokeDialog

▪ HotSpots (CHotSpots) Add

▪ DisplayArea (CDisplayArea) Text

Scripting
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UWIN-829 The wIntegrate Administrator is the main interface to the
wIntegrate Server. It shows user login events and allows control
over options such as logging and security. The Monitor shows
end-user screens with real-time updates. It can also allow users
to enter data into end-user sessions, similar to the U2 TANDEM
command.

Under each user's logon credentials, there are individual flags
to permit use of 1) the Administrator, 2) the Monitor, and 3) the
Monitor's keystroke entry feature.

The Administrator can be used by any authorized user on the
network. However, this feature can be disabled by clearing
the Remote Administration check box. When Remote
Administration is turned off, the Administrator can only be
used on the server where the wIntegrate Server is installed. The
Administrator cannot be disabled on the server.

The Administrator Options dialog box now has two similar
new check boxes that globally enable or disable 1) the Monitor
generally, and 2) the Monitor's keystroke entry facility. Note
that these two new check boxes take effect on all computers,
including the one on which the wIntegrate Server is installed.

Thin Client
Deployment

UWIN-831 The UserStat.exe application is optionally installed with
the local version. It shows all wIntegrate users on the network.
UserStat is now also installed with the wIntegrate Server. It is
not added to the Start menu. It can be run from the Program
Files\wIntServ folder.

Thin Client
Deployment

UWIN-834 The program would crash when using the DialogBox
ResetControls (option 0) call. It was caused by a clash in
initializing and resetting a control that had been subclassed. We
believe this bug was introduced in v6.0.1 when we introduced
support for coloring the foreground and background of combo-
boxes. This has been fixed.

Scripting

UWIN-835 A Trial version of wIntegrate can be downloaded from the
Rocket U2 web site. This installer has the same features as the
regular installer, but the evaluation period is different. The Trial
version installer did not install the following five files:

▪ C:\Program Files\wIntegrate\Docs
\WhatsNew621_Summary.htm

▪ C:\Program Files\wIntegrate\Docs
\WhatsNew621_User.htm

▪ C:\Program Files\wIntegrate\Docs
\WhatsNew621_Developer.htm

▪ C:\Program Files\wIntegrate\Docs
\WhatsNew621_Issue.htm

▪ C:\Program Files\wIntegrate\wIntSys\Script
\SystemMenu.wis

This has been fixed.

Installation
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UWIN-836 The Editor imports files from the U2 host using wIntegrate's
standard Import File and Export File functions. After a file
has been transferred, parameters for the file transfer are
intentionally left in the various fields for possible reuse. Every
process that wants to transfer files must clear these earlier
parameters when appropriate. If the user used Run > Import
File to populate an Excel spreadsheet with host data, and set
some of the Advanced options, these parameters were not
subsequently reset by the Editor. So when the user started
the Editor and imported a host program for editing, these old
parameters could prevent the file transfer. This has been fixed.
The Editor now resets all of the parameters.

File Transfers

UWIN-841 The File Transfer Monitor is displayed when using Query Builder,
Import File and Export File to transfer files between the host and
PC. The File Transfer Monitor has a View button that toggles a
panel showing small samples of the transferred data. The data
shown in the Viewer is being duplicated in the display. This has
been fixed.

File Transfers
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UWIN-843 A customer needed to determine whether a text field in a dialog
box had been edited by the user, regardless of whether the
value in the field had been changed. This is possible with the
WIN.DBGET subroutine. The following workaround is sufficient
for edit fields using type-ahead. The host basic program
controls where the focus goes after each field. The steps are as
follows:

1. Before setting the focus to the new edit field (edit1 on
dlg1), clear the Modified flag and set a global variable to
say it needs to be returned.

ALL WIN.COMSUB(“dlg1.edit1.modified=0;Global 
has_modified= true”)

2. If it is not an edit field, set the global variable to say it does
not have a modified field.

CALL WIN.COMSUB(“Global has_modified = false”)

3. The key press for the navigation keys is then created in
script to pass back the flag for the current field. To do this,
replace the standard call when creating the dialog box:

CALL WIN.DBKEY(DBX, ...)

with:

DBX<-1>=”SetKey Tab,`\mIf has_modified Then; 
mp=currfield:'.modified'; 
Modified = $mp; Else;Modified = 1;EndIf; 
Enter '\002K; dlg1; Tab; ':Modified,1`”

Where Tab is a navigation key (you will need to repeat this
for each key).

4. If the field is modified or is not an edit field, then the
call to WIN.DBEVENT2 will return with EVENT = “K”,
CTRL.NAME = key name, and ARGS = 1. Otherwise, if it was
not modified, then ARGS = 0.

5. WIN.DBGET can then be called if the field needs to be
retrieved.

Further refinements can be made to this technique, for
example, sending the value down at the same time or using
cached scripts for the key code.

Host Routines
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UWIN-844 The grid is used by the Report Viewer, which is one of the
destination options in the Query Builder. It is also used
extensively buy developers who created custom applications
with wIntegrate. Double-clicking on the column headings
of the grid now detects the type of data in the column, and
automatically sorts as follows:

▪ Text: left-justified

▪ Numbers with/without decimal places: right-justified

▪ Numbers with a single currency symbol: right-justified

▪ Dates and times: common formats and delimiters

Four currency symbols are currently supported:

▪ $ - dollar symbol used in USA, Australia, New Zealand, etc.

▪ £ - pound symbol used in the UK and countries in the Middle
East

▪ € - Euro symbol

▪ ¥ - Japanese Yen, Chinese Yuan

Scripting

UWIN-845 The grid is used by the Report Viewer, which is one of the
destination options in the Query Builder. It is also used
extensively buy developers who created custom applications
with wIntegrate. You can double-click the column heading in the
grid to sort the data by the contents of that column. You will find
that sorting data now takes less time than before. We tested this
with 20,000 rows.

Scripting

UWIN-846 A new grid was introduced with the 6.2.0 release. The new grid
did not support dragging columns left and right, or rows up and
down. This feature has been reintroduced with this release.

Scripting

UWIN-847 In this release, you can click, Shift-click and Ctrl-click either
rows or columns to select them with the mouse. Selecting a new
row of column replaces any existing selections. Selected rows or
columns can be copied to clipboard and other destinations.

Scripting

UWIN-848 A new grid control was introduced with the 6.2.0 release. This
grid did not support the date/time control type, which had
been supported in previous releases. The date/time control is
reinstated in this release. We have reimplemented the Set/Get
Cell/Range Attribute to allow setting of date/time attributes.
Also Set/Get Column Attribute can set attributes for a whole
column. Please see the Client Scripting Reference for syntax. A
new example script, GridDate.wis, demonstrates the use
of this control type. It is installed into the Program Files
\wIntegrate\,Example\Script folder when you select
Developer Additions during installation.

Scripting

UWIN-853 A new grid was introduced with version 6.2.0. It lets you set
the justification for a cell or column to Right or Center. When
you entered a value in the cell, and then moved the focus to a
field outside the grid (such as an edit box or push button), the
justification for that cell was not applied to the value entered.
This has been fixed. It now applies formatting/justification when
focus leaves the control.

Scripting
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UWIN-854 A new grid was introduced with version 6.2.0. Setting properties
with, for example, the Grid.Colwidths property did not work
beyond 128 columns. This has been fixed. It now sets properties
for up to 65 K columns.

Scripting

UWIN-856 There was a bug in the DateTime control when years were
shown with two digits. Increment or decrementing the date with
the arrow keys or the spinner made the internal date invalid as
store internally. This has been fixed.

Scripting

UWIN-857 In the grid, the ResizeRowToFit method sets the depth of the
row to accommodate the text in the cells. The ResizeRowToFit
method did not work correctly when the row had floating cells,
where text is displayed in a single line across adjacent cells
instead of wrapping in a single cell. It set the row depth too
deep as though all of the text were displayed in one cell. This
has been fixed. The ResizeRowToFit method now takes floating
cells into account.

Scripting

UWIN-861 A new grid was introduced with version 6.2.0 release. There
was a cosmetic display issue with horizontal scrolling. Suppose
a grid has too many columns to display in a single view and
the left-most columns (for example columns 1-10) are fixed in
position. The other columns to the right can be scrolled left and
right. When scrolling columns to the right everything worked
fine. But scrolling back to the left caused the first of the fixed
columns to flicker. This has been fixed.

Scripting

UWIN-864 Dates and times are entered as separate elements of day/
month/year and hours/minutes. In the previous release, the
user had to use the Tab or Arrow keys to move to the next
element, for example 12<tab>23<tab>11. In this release, the
FastEntry property causes the date/time control to move
automatically to the next element during user input, so the user
can now enter simply 122311. The FastEntry property defaults
to On.

Scripting
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UWIN-865 Here are some issues discovered in the grid.

▪ Custom column and row headings were not always shown
because the GridSetRowRange function did not work
properly.

▪ Double-clicking a column to sort it left the column selected.

▪ The ClearRange grid method could crash if used to clear
column headings.

▪ The grid click and right-click events did not generate events
when you clicked a row or column heading.

▪ When the old ActiveX GUID was used, the dialog box failed to
appear. The program now automatically creates a new style
grid if the control statement specifies this old GUID.

▪ The (X, Y) coordinates returned for cell clicks were relative
to the window. In pre-6.2.0 versions, they 6.1.3 they were
relative to the grid. This has been changed for backward-
compatibility.

All these have been fixed.

Scripting

wIntegrate v6.2.2
Release Date: February 2011
These release notes provide information about enhancements and fixes in wIntegrate v6.2.2

Enhancements and fixes in wIntegrate v6.2.2

The following issues were addressed in this release:

Issue
Number

Description Component

UWIN-22 The Query Builder is an easy way to transfer host data to the
desktop. Settings can be saved for reuse later. When saving
settings, a Browse button shows a dialog box that lets you
choose the folder where the settings will be saved. This dialog
box was expecting the user to enter the file name for the
settings, and saved the file immediately. Then, back in the main
dialog box, the file would be saved again. This was confusing.
The Browse button now shows a dialog box that simply lets you
select the folder. It no longer expects nor allows the file name to
be entered.

File Transfers

UWIN-211 The Edit > Copy Special To dialog box now has a new Border
check box in the Bitmap Options section. When the Border
check box is selected, a one-pixel black border is added when
copying from the host screen to clipboard as an image.

Terminal Emulation
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UWIN-591 Most of the developer information on wIntegrate is common
to the Windows and Java versions. However, there is a small
but growing number of points on development that are specific
to the Java client. Examples include supported parameters
in HTML files, and the ability to have pop-up or embedded
dialog boxes. Currently, this information is scattered in various
places and it should be brought together. As there is not enough
material to create a new manual, the Client Scripting Reference
has a new appendix that describes the differences in the Java
client. Also, every command and function that works differently
in the Java client is now documented accordingly.

Scripting

UWIN-716 In the Setup > Communications, SSL dialog box, selecting
the KeepAlive check box should cause a meaningless packet
to be set to the host periodically. This prevents the host from
closing the connection due to inactivity. A setting in the Registry
determines how often the KeepAlive is sent. However, turning
on the option in the Setup SSL Communications dialog box did
not cause the packet to be sent.

In v6.2.1, we fixed a bug where the KeepAlive did not work for
Telnet after opening a session with the KeepAlive turned on.
However, it did work when you went into the dialog box and
turned the flag off, then went back in and turned it on again. See
UWIN-219.

In SSL, it did not work under any circumstances. This has now
been fixed. See UWIN-717 for details of how to change the
KeepAliveTime from the default of two hours.

UWIN-717 The Setup > Communications, SSL setup dialog box has
a Telnet tab where you can select the TCP/IP KeepAlive
function. When KeepAlive is selected, a meaningless packet
is sent periodically to the host to prevent it from closing the
connection due to inactivity. Selecting the check box activates
the KeepAlive functionality that is built into the TCP networking
functions.

The dialog box now has a KeepAliveTime text box, which
lets you set the number of seconds of inactivity before the
KeepAlive packet is sent. Previously, the KeepAlive was the
system default of two hours but this was too long for many
users. The KeepAlive status and the KeepAliveTime can be
configured differently for different sessions. The values are
stored only in the session .WIC files so the Registry is not used.

Communications

UWIN-726 OLE Automation returns Time-Date values as floating point
numbers. An error in the processing of floating point numbers
meant that the number was being truncated, affecting the value
of the time returned. The Fractional part was handling only 6
digits. It now handles 20 digits. This is fixed.

Scripting

UWIN-727 Scripting supports the floating point functions FAdd, FSub,
FMul, and FDiv. An error in the processing of floating point
numbers meant that the number was being truncated, affecting
the value returned. The fractional part was handling only 6
digits. It now handles 20 digits. This is fixed.

Scripting
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UWIN-732 Terminal emulators support "attributes" on the character
screen such as Dim, Reverse, Flash, and Secret. The Flash
attribute causes the foreground color to blink by disappearing
and reappearing. This is the correct functionality and has
been in the product for many years. In very early versions of
the product, flashing was achieved by switching to a different
character attribute. For example, if text was displayed with the
ReverseFlash attribute, the flashing was achieved by adding/
removing the "Secret" attribute. So the user saw alternating
ReverseFlash and ReverseFlashSecret. This gave a very strong
flashing effect as the background was also flashed. This
functionality is now available again as an option, as follows.

The Setup > Colors dialog box has an Advanced button that
causes an extra part of the dialog box to appear.

The Advanced part of the dialog box has been improved slightly.
It is arranged in three groups, and it made sense to rearrange
these. So the middle group has been moved to the top and now
has a group-box caption of "Selected Attribute". The group
with the caption "Version 3 Compatibility" was at the top and
has been moved to the middle. To address this enhancement,
the "Version 3 Compatibility" group now has a new checkbox
Effect Flashing. When this check box is on/off, the Secret
attribute is always on/off for flashing attributes. This is the same
functionality as versions up to 4.x. It gives some flexibility as
follows:

Two examples with the screen attribute as ReverseFlash:

▪ With Effect Flashing turned Off (default, existing
functionality)
Assuming the ReverseFlash attribute is set to black text on a
red background, only the black text will flash on and off. The
background will always be red.

▪ With Effect Flashing turned On
Assuming ReverseFlash is again black on red, and the
ReverseFlashSecret attribute has been customized to show
white text on a black background, the black text on red
background will flash alternately with white text on a black
background.

This is much more visible and can be used to make on-screen
information unmissable, which might be important, for
example, in a 911 dispatch system. The Secret attribute color
combinations can be customized as required.

Terminal Emulation
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UWIN-740 Automation, previously known as OLE Automation, is the
interprocess communication mechanism that is used by
Windows COM applications. Previously, the program did not
support automation properties that had a Locale ID (lcid) as
part of their definition. Support for this has now been added,
which uses the current system lcid automatically for this type of
property.

Sample code:

* XLWorkBook is a previously obtained Excel 
workbook object
Object set bip = XLWorkBook.BuiltinDocumentProperties
Object set authorProp = bip.Item('Author')
authorProp.Value = 'davidr'
Object Release authorProp
Object Release bip  

Here is how to run the same instructions from the U2 host
using the WIN.COMSUB host subroutine rather than the usual
automation subroutines.

CALL WIN.COMSUB("Object set bip = 
XLWorkBook.BuiltinDocumentProperties")
CALL WIN.COMSUB("Object set authorProp = 
bip.Item('Author')")
CALL WIN.COMSUB("authorProp.Value = 'davidr'")
CALL WIN.COMSUB("Object Release authorProp")
CALL WIN.COMSUB("Object Release bip")

Scripting

UWIN-741 Version 6.2.1 had a new host subroutine WIN.MSGBOX2, which
displays a MessageBox with a large amount of text. This routine
had a bug under certain circumstances. It has been fixed. As a
temporary workaround, the user could:

1. Delete subroutine 100 (though it will not stop it working if it
is left there)

2. Change the line: TVALUE = "MapChars(":txt:")"
to: TVALUE = "MapChars(":TVALUE:")"

Host Routines

UWIN-742 The Listbox styles LBS_DISABLENOSCROLL and
CBS_DISABLENOSCROLL are documented in the Client Scripting
Reference, but did not work because the constants were not
defined in the code. This has been fixed.

Scripting
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UWIN-743 A new script function, U2mark, returns the current U2 mark
characters for the current host encoding. The Setup > Terminal
dialog box lets the user choose the Host Encoding. This converts
characters between the encoding method used on the host
and the Unicode encoding used internally by wIntegrate. In this
release, a new option, UVUTF-8, has been added to simplify
support for UniVerse NLS.

The U2 system delimiter characters are usually 251-255.
However, when UVUTF-8 is used, we have to use different
characters to avoid duplication with real Unicode characters.
When Host Encoding is set to UVUTF-8, we use the following
marks internally:

▪ 255 (IM) - U+F8FF

▪ 254 (AM) - U+F8FE (also known as FM)

▪ 253 (VM) - U+F8FD

▪ 252 (SVM) - U+F8FC

▪ 251 (TM) - U+F8FB

The new U2mark function help the user parse strings containing
these characters, by returning the correct delimiter characters
according to the host encoding. With UVUTF-8 host encoding,
asking for the Value Mark will return U+F8FD. Similarly with
Latin I host encoding, the VM will return 253. See the Client
Scripting Reference for more information and syntax.

Terminal Emulation
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UWIN-743 The Setup > Terminal dialog box lets the user choose the Host
Encoding. This converts characters between the encoding
method used on the host and the Unicode encoding used
internally by wIntegrate. A new option UVUTF-8 has been added
to simplify support for UniVerse NLS.

In version 6.1.0, we added support for UTF-8, which is the
standard encoding method for Unicode characters. UTF-8 is
generally used by web-based applications. It is how UniVerse
NLS stores data. However, there are some issues when using
UTF-8 with UniVerse NLS because of the characters 254 (AM),
253 (VM), 252 (SVM), and 251 (Text Mark). These have a special
functions as delimiters within UniVerse.

We could have added special coding to handle the 254, 254,
252, and 251 characters automatically behind the scenes
when UTF-8 encoding is active, but this might affect non-U2
users. So we have added a new Host Encoding type of UVUTF-8
specifically for use with UniVerse NLS. It works as follows.

A Value Mark (VM) is character 253. With Host Encoding set
to ASCII, character 253 is shown as a ý character (a "y" with
an acute accent as seen when running the wIntegrate script
chrset.wis in Program Files\wIntegrate\Example
\Script). However, with UVUTF-8, we cannot use the ý
character as this represents a genuine Unicode character. We
could translate it coming in, but then it would be ambiguous
and we would not know when to translate it going back to
UniVerse. So internally we use the following characters:

255 (IM) - U+F8FF

254 (AM) - U+F8FE (also known as FM)

253 (VM) - U+F8FD

252 (SVM) - U+F8FC

251 (TM) - U+F8FB

There is no visual representation for these characters, so they
show on the wIntegrate screen as squares. To help the user
parse strings containing these characters, there is a new script
command U2mark that returns the correct delimiter characters
according to the host encoding. So with UVUTF-8 host encoding,
asking for the Value Mark will return U+F8FD. Similarly with
Latin I host encoding, the VM will return 253. See the Client
Scripting Reference for more information.

Terminal Emulation
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UWIN-744 In v6.2.0, we introduced a new grid. Some issues were fixed in v
6.2.1; see UWIN-693.

V6.2.2 has fixed more issues as follows:

▪ The Checkbox did not work properly.

▪ Turning off the column heading turned off the row
"heading" (the leftmost column).

▪ A column heading that appeared on one line in v6.1.3
might break into 2 lines in v6.2.1. This happened when the
available space in the cell was fully occupied, and the way
the text is measured in the new grid meant it might be one
or two pixels too wide, and so would wrap onto the next line.
But the row was set to display only one line of text, not two,
so the text was hidden. Now in v6.2.2, if the text does not
fit or wrap into the width and height that is available, it is
clipped. This is helpful because the user can see that part of
a word is missing.

▪ Resizing the column heading depth with
ResizeRowsToFit did not work. The
ResizeRowsToFit command was not taking into account
the gap at edge of cells.

▪ When scrolling through the grid using the mouse and scroll
bar, the grid display only changed after the mouse button
was released. This was fixed by changing a simple internal
flag that had not been enabled.

▪ The check boxes have been moved up 2 pixels so they do not
overrun the base of the grid.

▪ The font setting is retained when the underline style is
added. Previously, the grid changed to the different, default
font when the underline style was added.

▪ Setting the Data property to "" caused a blank row to be
inserted. It is now ignored as in the previous grid.

▪ Setting the drop-down ComboBox for individual cells caused
problems.

▪ The drop-down ComboBox could occasionally contain
spurious characters in the text.

Scripting

UWIN-748 This item is reported for reference only. Visual Studio 2008 has
a code analysis too. It finds potential errors in the source code
that are not reported by the compiler. We ran this tool on the
wIntegrate source code. As expected it found some "errors" that
we fixed. On examination, as far as we know, they never caused
problems. Even so this has been a useful exercise.

Other



wIntegrate v6

78

Issue
Number

Description Component

UWIN-749 FOR/NEXT loops are now implemented in scripting. Previously,
looping was achieved by LOOP/WHILE/REPEAT syntax. FOR/
NEXT loops require less code, and are faster to execute than
LOOP/WHILE/REPEAT because there is only one variable to
evaluate every time around the loop.

Syntax:

FOR <var> = <first> TO <last> [STEP <step>]...NEXT <var> 

Example:

For j = 10 To 1 step -3
* j will be 10, 7, 4 and 1 in turn
Display Text "The value of j is " : j : CHAR(13) : CHAR(10)
Next j

Full details are in the Client Scripting Reference. Note that the
new "Next" command means that the word "Next" can no
longer be used as a subroutine name within a script. This will
report a script error. However the use of "Next" as a variable
name continues to work as before.

Scripting

UWIN-752 Previously, the grid had to be populated with data before the
cell properties could be set, including the properties SetColFont,
ReadOnly, BackColor, ForeColor and Control, List, Float. This
was awkward to code, and meant the grid could flicker slightly
because the font/colors were initially set to the default values
before the required values are applied. Also, every time a new
row was appended, the required properties had to be applied to
each of the new cells.

In this release, you can set default cell properties for the entire
column in the Init event of DialogBox OnDialogEvent / DialogBox
InitCommand. This simplifies setting up a grid and adding
rows. Setting properties for the defined range continues to be
supported.

Scripting

UWIN-753 Scripting supports display of images in several popular
formats. In v6.2.0, we changed some internal functionality that
prevented TIFF images from being displayed. In this release TIFF
images are supported again.

Scripting
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UWIN-754 When data is sent across networks, it is split into packets, which
are automatically joined together on the receiving computer.
Rarely, for no apparent reason, we see issues where data
has been lost. This can happen when changes are made to
networking infrastructure, or when either the host or client
computer runs very slowly.

In the Serial, TCP/IP, and U2 SSL communications, we have
implemented Transmit Delay and Transmit Block Size to
slow down the communications. Transmit Delay is a number of
milliseconds to pause between blocks of characters transmitted
to the host. The larger the value, the slower communications
will be. The default value is 0. Transmit Block Size box is the
number of characters in each block transmitted to the host
computer. The default value of zero specifies the fastest
possible transmission, with no restriction on the number of
characters in each block. The smaller the number, the slower
the communications as a larger number of smaller blocks will
be sent. The larger the number, the faster the communications
will be.

Communications
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UWIN-756 The build process creates both .EXE and .MSI files for each of
the applications. Either can be used to install the product. Some
customers want .MSI files so they can create custom installers,
which can be particularly important when making an installer
with pre-determined settings for a large number of users. In the
past, we distributed .MSI files to customers on an ad hoc basis.
In this release, they are included on the product CD in the wInt
\MSI folder. They are not referenced on the CD menu.

The files supplied are:

▪ wIntegrate.zip

▪ wIntegrate_Server.zip

▪ wIntegrate_Client.zip

▪ wIntegrate_Administrator.zip

▪ wIntegrate_Monitor.zip

We do not supply a .MSI file for the Manuals installer. Zip files
are created because along with each .MSI file there is a set of
much smaller (around 50 K) .MST files with installers in different
languages. For example, wIntegrate.zip contains the following
files:

▪ wIntegrate.msi

▪ 1028.mst - Chinese, Taiwan

▪ 1029.mst - Czech

▪ 1031.mst - German, Germany

▪ 1033.mst - English, United States (default embedded in the
executable)

▪ 1034.mst - Spanish, (Spain (Traditional)

▪ 1036.mst - French, France

▪ 1040.mst - Italian, Italy

▪ 1041.mst - Japanese

▪ 1042.mst - Korean

▪ 1045.mst - Polish

▪ 1055.mst - Turkish

▪ 2052.mst - Chinese, China

▪ 2070.mst - Portuguese, Portugal

Support for non-English languages is generated by InstallShield,
which provides the foreign-language text. This was
implemented some years ago. It is not required to meet Rocket
standards, but it is easier to leave in than take out.

Installation

UWIN-757 When a URL is displayed on the character screen, you can click it
to automatically display the page in a browser. This is done by a
script Click.wis in folder Program Files\wIntegrate
\wIntSys\Script. Previously the script recognized URLs
beginning with the text http and www. It now also recognizes
URLs beginning with https.

Other
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UWIN-758 This is a trivial item mentioned for the record. Following the
recent grid bug fixes, we added some new grid tests to the
automatic regression tests. One of these uses a menu that
highlighted a small difference in the way the local version and
the Windows thin client handle a script "error" concerned with
menus. If a script attempt runs Menu Detach to detach the
submenu from an invalid position on the menu (for example
specifying position 3 for a menu with 2 items), then the Windows
thin client treats this as an error and displays the script monitor.
However the local version does not report this as an error and
just continues. We have made the Windows thin client work the
same way as the local version, so an error is no longer reported.
This works like U2 Basic where you can DELETE a non-existent
value from a dynamic array without an error being generated.

Scripting

UWIN-770 On the US keyboard, the key on the top left hand corner next
to the "1" key represents the backquote and tilde characters, `
and ~ respectively. This key is one of the National Characters,
which vary from region to region. The National Character
numbers and the characters they represent can be seen on
the Key Definition tab in Setup > Keyboard as part of the
Alphanumeric keys, and also in the Keyboard Display tab. For
example, the backquote key is shown in the United Kingdom
keyboard as National12(`). This setting is correct for the United
Kingdom keyboard, but on the US keyboard the backquote key
should use National7. wIntegrate was using National12 for the
backquote key in error. The US keyboard does not have a key
assigned to National12. The consequence was that any custom
settings for this key were not respected. This bug has always
been present in the program. This has been fixed.

Terminal Emulation

UWIN-771 In v6.2.0, we introduced a new grid. The grid is used by the
Report Viewer (as an output option in Query Builder), and as
a copying option when right-clicking on the terminal screen.
In the previous version of the grid, it was possible to select all
cells by clicking the blank cell in the top left corner (where the
column headings and row headings intersect). This feature was
not present in the new grid. In this release, this feature has been
re-instated.

Scripting
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UWIN-773 Clicking the icon in the top left hand corner of the window
shows the System Menu. We added two options to this menu -
Always On Top and Restore Menu. The Restore Menu option
lets you turn on the application File/Edit menus when they are
not shown. This is an essential recovery feature for many users;
however, developers of certain types of application want to
turn off the File/Edit menus and prevent users from redisplaying
them. This was possible in version 3.x.

In this release, the Restore Menu option on the System
menu runs a script SystemMenu.wis in Program Files
\wIntegrate\wIntSys\Script. As shipped, the script
restores the application menu as per previous functionality.

Developers can customize this script as required to restrict or
enhance functionality. If the SystemMenu.wis script is not
present, then the menu is restored as per previous functionality.
Otherwise, a script error would occur for those developers who
customize the installer but fail to include the new file.

Setup and
Configuration

UWIN-774 The wIntegrate Administrator is a front-end interface for
the wIntegrate Server. It controls application settings and
shows connection events. The Recovery tab controls how a
disconnected thin client will reconnect to the wIntegrate Server.
The Auto End Session parameter specifies the number of
minutes after which the session will be terminated if the user
has failed to reconnect. In previous releases, the default value
for Auto End Session was zero, meaning that the automatic
timeout was disabled. This value is better set to 30 as there is a
separate check box to enable/disable the function.

Other, Thin Client
Deployment

wIntegrate v6.2.1
Release Date: October 2010
These release notes provide information about enhancements and fixes in wIntegrate v6.2.1

Enhancements and fixes in wIntegrate v6.2.1

The following issues were addressed in this release:

Issue
Number

Description Component

UWIN-35 The new SSH Communications in version 6.2.0 had a bug
where not all characters were read from the input buffer and
processed. This was a relatively rare and random issue. It was
usually obvious to the user as a block of typically one or two
hundred contiguous characters was lost so the screen display
was corrupted. This has been fixed.

Communications
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UWIN-39 When the screen was set to 132 columns, the Linux vi command
used only 80 columns. The full 132 columns were used for other
Linux commands such as ls and cat. Also, formatted U2 screens
were displayed correctly in 132 columns. There is a fundamental
difference between Telnet and SSL (which are communication
protocols) and SSH (which is a shell). So, unlike Telnet and SSL,
the concept of a terminal screen is embodied within SSH. This
requires a slightly different approach in wIntegrate. The menu
option Setup > Terminal lets the user set the screen size in
columns and rows. In the session .WIC file these variables are:

▪ Columns = 80

▪ Lines = 24

When SSH is in use, it has its own settings for columns and
rows. We do not provide a user interface to these values. In the
session .WIC file these variables are:

▪ TerminalWidth = 80

▪ TerminalHeight = 24

In the 6.2.0 release, the values for TerminalWidth and
TerminalHeight were always 80 and 24, regardless of values set
by the user in Setup > Terminal. The program has now been
modified so that the values from Setup > Terminal are picked
up and applied by the SSH communications, but only when the
connection is first made.

Communications

UWIN-43 In previous releases, the Administrator always connected to
the wIntegrate Server on TCP/IP port 55639. The port that is
used is now configurable to improve flexibility, and possibly to
avoid contention with other products that might use the same
port. The Administrator has a text box where the TCP/IP port
can be changed. The wIntegrate Administrator has a new tab
that allows the TCP/IP port used by the wIntegrate Server to
be configured for the various client applications, including the
Administrator.

Thin Client
Deployment

UWIN-52 In previous releases, the Windows and Java thin clients always
connected to the wIntegrate Server on TCP/IP port 55638.
The port used is now configurable to improve flexibility, and
possibly to avoid contention with other products that might
use the same port. The wIntegrate Administrator has a new tab
that allows the TCP/IP ports used by the wIntegrate Server to be
configured for the various client applications.

The thin client applications (the Windows thin client and the
Java client) have a new Advanced button on the initial login
page, which lets the user configure the TCP/IP port used by the
client. As with other parameters, the TCP/IP port can be set as a
command-line option. For example, for the Windows thin client
the syntax to set the port to 56789 would be:

C:\Program Files\wIntCli\wIntCli.exe -TCPIPPort
56789

Thin Client
Deployment
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UWIN-55 In previous releases, the Monitor always connected to the
wIntegrate Server on TCP/IP port 55640. The port used is
now configurable to improve flexibility, and possibly to avoid
contention with other products that might use the same port.
The Monitor has a text box where the TCP/IP port can be
changed. The wIntegrate Administrator has a new tab that
allows the TCP/IP ports used by the wIntegrate Server to be
configured for the various client applications, including the
Monitor.

Thin Client
Deployment

UWIN-164 The Client Scripting Reference has been updated with an
additional parameter that was not previously mentioned. This
is the fifth parameter, the window state, of the Get(Window)
function. The fifth parameter controls the Minimize/Maximize/
Hide/Show property of the window.

Documentation

UWIN-167 Version 6.1.0 implemented connection recovery between
the thin client and wIntegrate Server. So if the client drops
the connection, the wIntegrate Server keeps the U2 session
active, pending the reconnection of the client. However if
the client never came back, the U2 session would stay active
indefinitely. The wIntegrate Administrator now lets you specify
the recoverability timeout for disconnected clients. The value is
entered in minutes.

Thin Client
Deployment

UWIN-181 The Heading and Footing fields in the Query Builder allows
parameters such as D and L to be resolved as Date and Linefeed
in the resulting report. These parameters can now be used
when the target is the Report Viewer - this built-in grid is a
much better way to view reports than the character screen.
The program has now been modified to resolve the following
parameters when the destination is the Report Viewer:

▪ D = current date

▪ T = current time

▪ L = line feed

▪ P = page number (always 1 in the Report Viewer as there is
no concept of pages)

▪ F = file name

Any justification for options P and F is ignored. Other
parameters cannot be processed and are stripped out.

Scripting



wIntegrate v6.2.1

85

Issue
Number

Description Component

UWIN-185 WIN.MSGBOX, WIN.INFOBOX, and WIN.DBMSGBOX are
different ways to display text up to 150 characters in a message
box. In this release, three new routines have been added to
allow more text to be displayed. We have left the original
routines unchanged for backward-compatibility reasons.

The new routines are:

▪ WIN.MSGBOX2 - displays a message box with optional
response buttons

▪ WIN.INFOBOX2 - displays text in an information box

▪ WIN.DBMSGBOX2 - displays a message box attached to a
dialog box

In each case, these are new versions of existing routines with the
same syntax with the difference that they allow large amounts
of text in the message. The message size is effectively unlimited
as it depends on the operating system and will fill the screen
many times over. We have to impose a maximum length on
the text as we cannot predict how customers will use this
new feature. These new routines are documented in the Host
Subroutines Reference.

Host Routines

UWIN-197 The wIntegrate Editor can open text files on a server and
save to that server. When using FTP, the Determine from
Host option makes the Editor get the directory path from the
server. However, it did not resolve Q-Pointers correctly. It failed
because the program tried to get the path from the VOC file
definition. When a file is defined in the same account, the file
path can be read from the VOC file definition, but this does not
work with Q-Pointers. The Editor now uses the path to the file
retrieved from the host to save the file (instead of the account
name). This means it handles Q-Pointers.

Other

UWIN-212 Some characters are valid in UNIX file names but not Windows.
Windows does not allow the following characters in filenames:
\ / : * ? " < >

An invalid character would cause FTP to hang when transferring
files from UNIX to Windows. The program now alerts the user
with a message if the path or file name contain characters that
prevent its use with Windows. The user has to correct this before
continuing.

File Transfers

UWIN-219 The Setup > Communications dialog box for Windows Sockets
(Telnet) has a check box to enable the KeepAlive. This causes
a meaningless packet to be sent to the server to prevent it
closing the connection due to inactivity. Selecting the check box
simply activates the KeepAlive functionality build into the TCP
networking functions. Although the KeepAlive function worked
properly immediately after selecting or clearing the check box,
it did not work when starting a session that had been saved with
the check box selected. This has been fixed.

Communications



wIntegrate v6

86

Issue
Number

Description Component

UWIN-670 Setup > Colors lets you specify an image to use as background
for the character screen. If the specified image file was not
present when the program started up, an error was reported,
and the interface initialization was not completed. We have
changed the sequence of events at startup. A missing or invalid
background image no longer causes an error.

Other

UWIN-686 Version 6.2.0 included a PDF file and code samples showing
how to convert a character application to GUI dialog boxes. This
is installed when the Developer Additions are selected during
installation. The PDF file was incomplete. This has been fixed.

Documentation

UWIN-687 The wIntegrate Editor's Edit menu already has the options
Make Uppercase and Make Lowercase, which apply to
selected text. The Edit menu now has a new option called
Toggle Case. This reverses the case of selected characters
between upper/lower case, and lower/upper case. The shortcut
key is Ctrl T.

Other

UWIN-690 Version 6.2.0 used a new grid control. The default row height
was deeper than in the previous grid. This meant that fewer
rows are displayed in a given space than before. We have
adjusted the default font so that it takes the less depth.

Scripting

UWIN-691 The wIntegrate Editor can upload/download files from the
U2 server using FTP. It automatically distinguishes between
Windows Sockets and SSL to establish the host name. It
should also recognize when SSH is in use and derive the host
name there when necessary. The Editor now recognizes and
distinguishes between Windows Sockets, SSL and SSH to derive
the host name for FTP file transfer.

Scripting

UWIN-692 The wIntegrate Editor can now open multiple programs from
the U2 command line, or from a desktop shortcut. The items are
opened as multiple windows in the same Editor session.

From the host, the syntax is:

WIN.EDIT  Filename  Item1  Item2  Item3  etc...

On the PC, the syntax is:

winedit.exe  -session  mysession.wic  -file  WIN.PROGS  -item  MYPROG1  -item  MYPROG2  -item 
MYPROG3  etc...

So the user can create a desktop icon that opens multiple items.
Note that the specified session must be at TCL in the correct
account for the programs to be imported.

Other
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UWIN-693 In v6.2.0, we implemented a new grid control, replacing a grid
that had been in use since wIntegrate 98. Due to differences
between the two grids, the new grid lacks some functionality in
the previous grid. This release fixes some bugs and adds some
new features:

▪ Floating cells. Data overlaps into the next cell if the next cell
is empty.

▪ Automatic wrap. Text in headings wraps onto more than one
line

▪ Cell borders. You can now add a border to the grid to
distinguish the headings.

▪ Radio buttons. Cells mow support radio buttons in addition
to check boxes and push buttons.

▪ Setting the Row Height could cause a script error. This has
been fixed.

▪ The ModifyCell event is supported.

▪ HideRows caused an error. It now allows the use of row 0 to
hide row headers.

▪ HideCols caused an error. It now allows the use of column 0
to hide column headers.

The following heading display issues were fixed. (Note that
their grid does not have a real heading, it is just a group of cells
painted to look like headings).

▪ The default row height has been changed.

▪ The column width is calculated differently (rounding errors).

▪ Floating cells ( spanning cells) would not overwrite more
than one column.

▪ Floating cells were being displayed a few pixels too low

▪ Justification was set for the whole column.

▪ Justification by cell has been reinstated.

▪ When two grids are positioned adjacent to each other, for
example when one has a simulated heading, they now clip
each other in a different way.

Grid lines did not show as the lines of the grid were the same
color as the cell background. The grid lines are now mid grey
(128,128,128) so they are visible.

ResizeRowToFit did not take into account wrapping in column
headers. We also fixed this for normal cells, and made it so
normal cells now always wrap text.

Column headers did not take into account justification from
ColWidths command.

Scripting
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UWIN-694 A customer reported that some characters were not displayed
properly when the France.wit Extension was selected in
Setup > Terminal. The France.wit terminal extension has
been changed as follows.

Old settings:

▪ MapTable = "@", "\226", "[", "\176", "\\", "\231"

▪ MapTable = "]", "\167", "^", "\238", "`", "\244"

▪ MapTable = "{", "\233", "|", "\249", "}", "\232", "~", "\234"

New settings

▪ MapTable = "@", "\224", "[", "\226", "\\", "\231"

▪ MapTable = "]", "\234", "^", "\238", "`", "\244"

▪ MapTable = "{", "233", "|", "249", "}"}", "\232", "~", "\251"

Terminal Emulation

UWIN-695 Setup > Communications for Windows Sockets (Telnet) and
SSL each have a Telnet tab. One of the options on this tab is
the Terminal Type, which wIntegrate attempts to negotiate
with the host when the connection is first made. The available
terminals in this list are taken from a terminals.txt file in
the Program Files\wIntegrate folder.

When specified, this setting overrides the terminal type
embodied in the current terminal emulation .WIT file. (Note
that the emulation .WIT files can be edited with the wIntegrate
Editor, installed when you turn on Developer Additions.)

The terminals.txt file did not include tvi965 as an
available type, though there is a tvi965 emulation. This has
now been added to the terminals.txt file. Note that the
terminals.txt file can be customized as required.

It is important to have a dedicated list of terminal types for
use in Setup > Communications, and also to allow users to
customize the list. In theory, it would be possible to use the list
of terminals shown in Setup > Terminal, but this could include
terminal names that are not valid on the server, and the list
could not be customized.

Terminal Emulation

UWIN-696 Vietnamese and Thai use non-spacing characters, meaning that
multiple input characters are displayed in a single character
cell. In Vietnamese, they are the diacritics (accents), which are
added to the previous character cell by a second keystroke.
There is a mismatch between the number of keystrokes and the
number of character cells used to display the input. wIntegrate
could crash when a language with these non-spacing characters
was used, and the user switched between 80/132 columns. The
code was not allocating enough memory internally for the non-
spacing characters. This has been fixed.

Terminal Emulation

UWIN-697 The program could crash after switching from an SSH
connection to Telnet (Windows Sockets). This was because an
internal resource was not properly being destroyed when the
user switched to another communications protocol. This has
been fixed.

Communications
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UWIN-698 When a script attempted to resize row 0, the header row
returned an error "6295 Grid row is outside range of rows in
Grid." This has been fixed. It is now possible to resize row 0.

Scripting

UWIN-701 Version 6.2.0 introduced support for SSH connections. In
the Setup dialog box, there is an SSH tab with the option
to set a Terminal Type. In this release, the terminal Type is
automatically set to vt220 rather than be left blank. This means
that $TERM on the host is always set. We decided not to set the
Terminal Type according to the terminal selected in Setup >
Terminal. For many people, this would work well, but for some,
the terminal emulation in wIntegrate might not match a valid
$TERM setting on the host, which could cause more confusion
than benefit when a change in one dialog box affects another.
On balance, we felt that the two fields are best kept unrelated.

Terminal Emulation

UWIN-703 Users should not be aware of this change. It is mentioned for the
record only. Version 6.2.0 was rebranded as Rocket Software.
Some additional internal files have had their names changed.

Other

UWIN-704 Support for ViewData emulation was removed from Version
6.2.0. The file terminals.txt in the Program Files
\wIntegrate folder is used in the Setup > Communications
dialog box. It shows a customizable list of available terminal
types on the host. We have removed ViewData from this file.
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UWIN-705 The wIntegrate Editor is the easiest way to edit .WIC
configuration files. It uses configuration .INI files to determine
keyword coloring, and display settings for the different file types
it supports.

The config.ini file specifies the settings when editing
session .WIC files, such as the default file Session1.wic. The
config.ini file is in the Program Files\wIntegrate
\wIntEdit folder. This file was not updated to take account of
the new SSH settings added in version 6.2.0. It was lacking the
following keywords relevant to SSH:

▪ PortNumber = 22

▪ KeyFileName = ""

▪ Protocol = "SSH2"

▪ TerminalWidth = 80

▪ TerminalHeight = 24

▪ LogFileName = ""

▪ LofFileMode = "Overwrite"

▪ LogRawData = 0

▪ LogDataPackets = 0

▪ LogSSHEvents = 0

▪ LogSessionData = 0

The standard config.ini file installed with the program
now specifies the new keywords. Note that this change applies
only when editing session configuration files with the .WIC
extension. Sessions can also be started by scripts with the .WIS
extension where the color settings and display parameters
are determined by the script.ini file, but the session
configuration keywords have never been specified in this file.

Other

UWIN-708 Setup > Communications has three options - Telnet (Windows
Sockets), SSL, and now SSH. In previous versions, these dialog
boxes expected the user to type in the host name each time it
changes. In this release, the host names are remembered in
a drop-down list. For easy manipulation, the host names are
stored in text files in the Program Files\wIntegrate
folder. The file names are:

▪ Telnet: HostsWindowsSockets.txt

▪ SSL: HostsSSL.txt

▪ SSH: HostsSSH.txt

Setup and
Configuration
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UWIN-709 wIntegrate works internally with data in Unicode. When data is
received from the U2 host, before it is displayed on screen, etc.,
it is converted to Unicode using the Host Encoding specified in
Setup > Terminal. However, data sent to the printer using slave
printing was not converted using Host Encoding. This means
that multi-byte characters such as Vietnamese were not printed
as the correct Vietnamese character but as the original bytes as
stored on the host.

The program now converts incoming data intended for slave
printing, according to the Host Encoding selected in Setup >
Terminal. Data is not converted if the Print Direct check box is
selected in the File > Setup Printer menu option. The purpose
of this option is to send data to the printer exactly as received
so that the host can determine the exact characters sent to the
printer.

Terminal Emulation

UWIN-712 The Setup > Communications dialog box for Windows Sockets
(Telnet) has a check box to enable the KeepAlive. When
KeepAlive is selected, a meaningless packet is sent periodically
to the host to prevent it from closing the connection due
to inactivity. Selecting the check box simply activates the
KeepAlive functionality built into the TCP networking functions.

The dialog box now has a KeepAliveTime text box that lets you
set the number of seconds of inactivity before the KeepAlive
packet is sent. Previously, the KeepAlive was the system
default of two hours, but this was too long for many users. The
KeepAlive status and the KeepAliveTime can be configured
differently for different sessions. The values are stored only in
the session .WIC files, so the Registry is not used.

UWIN-714 Version 6.2.0 uses a new grid. While working on 6.2.1 to fix
issues in the new grid, we realized that developers would
appreciate the ability to set some default values. None of these
are supported in the Java client.

▪ Default font for the entire grid.
The Font setting for the grid now sets the font for all cells in
the grid.

▪ Default font for column and row headers
Two new script commands RowHeadersFont and
ColHeadersFont set the default font for Row 0 and
Column 0. Note that the grid does not have real column and
row headers; they are just Row 0 and Column 0 of the grid.

▪ Default row height
The new script command DefaultRowHeight sets the
default row height for all rows in the grid.

These new routines are documented in the Client Scripting
Reference. We have decided not to implement setting the
default column width at this time.

Scripting
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UWIN-715 The Script Monitor appears when a script error is encountered.

If a script had multiple errors, and you pressed the Ignore
button, the Script Monitor disappeared for the first error but did
not return for subsequent errors.

For example, this script statement has three errors: PRANT "a";
PRBNT "b"; PRCNT "c"; PRINT "d"

It shows the Script Monitor because PRANT "a" is not a valid
script command. After clicking Ignore, the script then stops at
PRBNT "b" as this is also an error, but the script error dialog box
was not shown.

A valid statement between two errors was executed, but the
error dialog box was still not shown for a subsequent error.

For example, this script also has three errors: PRANT "a"; PRINT
"hi"; PRBNT "b"; PRCNT "c"; PRINT "d"

After clicking Ignore at the PRANT "a" error, the PRINT "hi"
statement would be executed correctly but the error dialog box
was not shown for the error PRBNT "b". This has been fixed.

wIntegrate v6.2.0
Release Date: June 2010
These release notes provide information about enhancements and fixes in wIntegrate v6.2.0

Enhancements and fixes in wIntegrate v6.2.0

The following issues were addressed in this release:

Issue Number Description

eCase 11626 When user does not have the correct permissions to create a directory, for example,
under C:\Program Files, the status_var flag is supposed to be set to reflect
the error. This did not happen – the value of status_var does not change when the
directory was not created. This has been fixed.

eCase 12102 The wIntegrate Editor would crash if the user attempted to use the Sample code
block on the Code menu. This was caused by the way Unicode is handled internally.
It has been fixed.

eCase 12446 When pasting text from the clipboard into the character screen, spurious ? characters
could appear at random embedded in the text. If the text was pasted again, the ?
characters might or might not appear in the same place. The ? characters were not in
the data on clipboard. This only happened on some machines.

We were able to reproduce this consistently and then fix it. We changed the part of
the code that removes control characters from the Unicode data about to be pasted.
We believe users should not experience this again.

eCase 12607 Developers wanting to display tooltips for objects in a GroupBox should be aware of
the required naming convention. Tooltips will only show for objects in a GroupBox
if the GroupBox name is set to "None." This is due to the way the underlying MFC
functionality works. This means the group box is a static Windows control, and
developers cannot set properties.
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eCase 12734 When attempting to export a third party .XLS file, the export could fail with the
error “Unable to read local disk drive.” This happened because the program was
not properly handing large internal string tables introduced with a recent version of
Excel. This has been fixed.

eCase 12854 The sample VB application vSession.net shows how the wIntegrate session
control wSession.ocx can be used with a .NET application. This is installed when
you select Developer Additions during installation. It is in the C:\Program Files
\wIntegrate\Example\VB folder. The sample has been updated to work with
Visual Studio 2008.

eCase 35798 The internal handling of the grid control has been changed. The appearance is
slightly different and some obsolete functionality has been removed. The Client
Scripting Reference manual has been updated accordingly.

eCase 35799 The date/time control has been rewritten to use the standard Windows control. The
Client Scripting Reference manual has been updated accordingly. The new date/
time control is now shown on the dialog box that is created by the host program
WIN.DBDEMO3. This is option 17 on the WIN.DEMO menu showing developer
samples.

eCase 35800 The calculator control has been rewritten using standard Windows controls.
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eCase 37404 A new option U2 SSH is available in Setup > Communications. The setup is similar to
Telnet and U2 SSL.

General tab:

▪ Host: Specify the host name. In the Host field, enter the name or IP address
of the host computer with which you want to communicate. To fix the
login for a particular user, you can include the user name in the format
myloginname@myservername.com

▪ Port: Specify the port. In the Port field, port number 22 is selected by default
because this is the standard port number for SSH. If your server uses a different
port for SSH, enter the port number.

SSH tab:

▪ Protocol: Select SSH1 or SSH2

▪ Terminal type: Select a terminal type. The terminal type is set by default to be
the same as the terminal emulation selected in Setup > Terminal. If the host does
not support this terminal type, click the scroll arrow to select the one you want. If
you change the terminal emulation in Setup > Terminal after you have selected a
different terminal type, wIntegrate resets the terminal type to be the same as the
terminal emulation.

▪ Client Authentication Key Filename: By default, the host accepts a user name
and password to authenticate a user. SSH supports an alternative method where
an Authentication Key file can be used to authenticate the user. We do not supply
a utility to create Client Authentication Key File. Third-party utilities are available
to create this file.

Logging tab:

▪ Log Filename: Enter the name of the file that will store logging information when
Log flags are turned on.

▪ Log File Mode: Select Append to add log data to an existing file, or Overwrite to
clear the log file every time a connection is made.

▪ Log Raw Data: Records the sent (unencrypted) and received (decrypted) binary
data.

▪ Log Data Packets: Records the details of each SSH data packet.

▪ Log SSH Events: Records a summary of each SSH authentication event.

▪ Log Session Data: Records the user data, including keyboard input and what
appears on screen.

To make your backspace key work properly, you might need to change the
Backspace setting in Setup > Terminal from the default value of Normal(8) to
Delete(127).

The Setup SSH dialog box has a Default button that changes the viewed settings
to those stored in the DefU2SSH.wis file. For the local version, this file is stored
in the username\wIntegrate\Default folder. For thin client users, it is in
the ProgramData\Rocket Software\wIntegrate Server\Users
\username\Default folder. Note that the files in the Default folders are copied
automatically from the Program Files\wInt...\wIntSys\Default to the
user's folder, but only when username first uses the relevant program. So if username
already has an earlier version of the program installed, the Default folder will already
exist for that user, so any new Default files will not be copied to the user folder.
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eCase 38503 Converting character-based applications to true GUI has been a long-standing
objective of many developers. A new Tech Note with sample programs/data shows
how this can be achieved.

In this example, a screen-driver program reads parameters from a file to control
each screen. The parameters are used to create a dialog box, and the screen-
driver is adapted to control this dialog box. Instructions are in the PDF titled How
to convert Character-based to GUI. All files mentioned here are in the Program
Files\wIntegrate\Host folder. The following programs are included in the
bp_demo.txt file:

▪ WIN.DEMOSD - initial application allows choice of character or GUI

▪ WIN.CHARSD - runs the character version

▪ WIN.GUISD - runs the GUI version

The data files containing a data record and screen parameters are contained in file
demodata.txt:

▪ WIN.SCREEND

▪ WIN.PERSON

▪ DICT WIN.PERSON

These host files and programs are installed to the U2 host (along with other sample
programs and files) by running the inst_dem.wis script.

eCase 39051 This change is mentioned for the record only. Users should see no changes in
operation. Previous releases of the program were installed using InstallShield 10.5.
Version 6.2.0 uses InstallShield 2009 SP2.

eCase 39428 When the wIntegrate Editor is started, it has no document open, and the user must
select File > New, then a format to use. A new Preferences dialog box on the Tools
menu lets the user choose the default document or action when the program starts.
The options are:

▪ None

▪ Ask

▪ Script

▪ Terminal emulation

▪ Host basic program

▪ Text

▪ Configuration session file

The default format is Text.
eCase 40539 The splash screen and Help > About dialog box in the Simplified Chinese version

were out of date. They have been updated to the new Rocket branding. See also
eCase 41635.

eCase 40592 A code-signing certificate is embedded into the Java client
(wIntJavaApplet.jar file). This certificate verifies the creator of the application.
The v6.2.0 release contains a new 3-year certificate that will expire on March 28,
2013. Previously, a 1-year certificate was used. This was first included with v6.1.3
(eCase 37415). Its expiration date is July 28, 2010. An expired certificate does not
prevent the executable from running, but it shows a warning message.
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eCase 40593 ViewData is an unusual emulation using a 40x24 screen instead of the usual 80x24.
It was used in some countries to provide text-based news services over analog
television broadcasts. In the United Kingdom, it was a popular interface for travel
agency systems. The ViewData emulation has been removed from the product.
The code was quite complex and complicated the rest of the internal emulation
processing. As it is no longer used, it has been removed.

eCase 40618 There was an error in outward conversion of masked decimals, where OCONV(999.9,
"MD2") returned 9.99 but it should return 10.00. This has been fixed.

eCase 40619 In Setup > Application, the Folders tab had a V4.0 Compatible button. This was
introduced in Version 5.x to make life easy for users who preferred not to use the new
My Documents folders, but to continue to store settings files in Program Files
\wIntegrate. Today, it is no longer feasible to store settings in the Program
Files folder as Vista prevents users from saving files there. This option is no longer
useful and has been removed.

eCase 40627 In the editor, the Folder Options dialog boxes let you specify the folders that are
used for code blocks, and for programs that are downloaded from the host. By
default, these locations are in the Program Files\wIntegrate folder. This is
not considered good practice and is discouraged by Microsoft. These user files are
now stored in the My Documents\wIntegrate folder.

eCase 40630 The inward conversion of "1000" is supposed to work in the same way as "10:00."
This was not working. Similarly, times such as "100" and "900" should be converted
to 1:00 and 9:00 respectively. Generally, on multi-valued systems, this type of inward
conversion is not supported. However, wIntegrate has always been coded for this to
work, but it did not work properly.

The inward conversion of 1000 is now treated correctly as 10:00. Also, the ICONV of
times now recognizes the following values as the respective times:

▪ 25 = 00:25

▪ 59 = 00:59

▪ 61 = invalid

▪ 100 = 01:00

▪ 959 = 09:59

▪ 961 = invalid

▪ 1000 = 10:00
eCase 40644 The ChangeUserSession script command lets developers control the thin

client login process with a script. It allows every user to log in automatically to the
wIntegrate server with the same temporary user name. A scripted dialog box lets the
user enter their real name and password once only. The session is then assigned to
the real user name and the session's .WIC file is copied to the real user's own folder.
We discovered that this process had a bug, as follows:

When Jim logs in, the user session is changed from the common user name to "Jim"
using the ChangeUserSession command. The program expects all of the files
to be in Jim's folders, but when Jim logged in, the original session file was created
in the general purpose folder that is used by all users initially. This discrepancy
prevented the original session file from being removed. So it is likely that these
session files could build up. It now moves the original session file to the user's folder
as part of ChangeUserSession, so it can be deleted later.



wIntegrate v6.2.0

97

Issue Number Description

eCase 40680 When data is sent across networks, it is split into packets that are automatically
joined together on the receiving computer. Rarely, for no apparent reason, we
see issues where data has been lost. This can happen when changes are made to
networking infrastructure, or when either the host or client computer is runs very
slowly. In the serial and TCP/IP communications, we implemented Transmit Delay
and Transmit Block Size to slow down the communications. Transmit Delay is a
number of milliseconds to pause between blocks of characters that are transmitted
to the host. The larger the value, the slower communications will be. The default
value is 0. Transmit Block Size box is the number of characters in each block that
is transmitted to the host computer. The default value of zero specifies the fastest
possible transmission, with no restriction on the number of characters in each block.
The smaller the number, the slower the communications as a larger number of
smaller blocks will be sent. The larger the number, the faster the communications
will be.

eCase 40797 The File > Save As dialog box lets you save the settings for the current session as
either a .WIC file (the default setting) or a .WIS script. In the dialog box, if you
choose Scripts (.WIS) in the Save As Type drop-down menu, the program would
hang. This has been fixed.

eCase 40813 The ScriptVersion command returns the version that is contained in a script.
If the specified script did not exist, the program crashed with an Access Violation.
You could verify this bug by running WC.WIS in Program Files\wIntegrate
\Example\Script, and running the following script statement:

MessageBox ScriptVersion(UserDir : "nonexistentscript.wis")

This has been fixed. As a workaround, you could check whether the script exists using
the FileExist command before getting the version.

eCase 40819 This item is of interest to Support personnel responsible for running the wIntegrate
Server. The wIntegrate Server now catches exceptions (execution errors) specifically
when reading the incoming communications. A new CONTACT SUPPORT message
is displayed showing the text "ReadComms" in the message if the exception occurs
around the internal readcomms call.
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eCase 40820 The wIntegrate Administrator now has a new Client Debug Logging check box. When
selected, log files are written showing the activity that is sent from the client to the
server with the time/date by user session. The folders that are used are as follows:

▪ Vista: ProgramData\Rocket Software\wIntServ\Logs

▪ XP: Documents and Settings\All Users\Application Data
\Rocket Software\wIntServ\Logs

Log files are created with IDs in the following format:
cl20091030_142333_103_drtest_127_0_0_1-10_0_0_16.txt

▪ cl = Client Log (to differentiate from other types of logs)

▪ Date file created, YYYYMMDD

▪ Time file created, in seconds

▪ unique rolling number to ensure ID is unique. Starts at 1 every time wIntegrate
Server is started

▪ IP addresses - PC running wIntegrate Server _ PC running wIntegrate client

Sample contents of file:

TIME DATE COMMAND
14:23:52 10/30/09 KC
14:23:54 10/30/09 KC
14:23:58 10/30/09 WI
14:23:58 10/30/09 GI
14:23:58 10/30/09 GI
14:23:58 10/30/09 WE
14:24:00 10/30/09 WE
14:24:00 10/30/09 RP
14:24:00 10/30/09 RP

The command mnemonics are for internal use for analysis by Level 3 support.
eCase 40831 In late 2009, the U2 database and tools business became part of Rocket Software,

Inc. This has meant changes to the branding and file locations. On the surface,
version 6.2.0 has different company branding with splash screens, and copyright
statements, etc. Internally, it uses different locations in the directory structure and
registry where the company name is used. Administrators should be aware that
wherever files were previously stored under "IBM," they are generally now stored
under "Rocket Software." Here are the folders with their old and new equivalents on
Windows 7 and Vista:

License file: License.wil. The old folder was C:\ProgramData\IBM\wIntegrate
License. The new folder is C:\ProgramData\Rocket Software
\wIntegrate License.

wIntegrate Server thing client users*. The older folder was C:\ProgramData
\IBM\wIntServ. The new folder is C:\ProgramData\Rocket Software
\wIntegrate Server.

* Note the renaming of this folder to the full product name.

The installer automatically moves files from the IBM location to the new Rocket
Software folders, so the IBM folder disappears. However, if the equivalent Rocket
Software folder already exists, then no files are changed, copied, moved, or deleted.
Following the same principle, entries in the Registry are also moved unless, for
example, "wIntegrate" or "wIntegrate Server" already exist in the Registry under
Rocket Software.
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eCase 40852 The ChangeUserSession script command lets developers control the thin
client login process with a script. It allows every user to log in automatically to the
wIntegrate server with the same temporary user name. A scripted dialog box lets the
user enter their real name and password once only. The session is then assigned to
the real user name and the session's .WIC file is copied to the real user's own folder.
We discovered that this process had a bug, as follows:

The ChangeUserSession command could cause a crash due to a conflict in
the multi-threading. If two people logged in at the same moment, one user could
release the details of the other user. We believe this crash was very unlikely as the
ChangeUserSession process happens very quickly.

This has been fixed. The handling of the multi-threading has been changed to
prevent user sessions from conflicting with each other.

eCase 40853 The ChangeUserSession script command lets developers control the thin
client login process with a script. It allows every user to log in automatically to the
wIntegrate server with the same temporary user name. A scripted dialog box lets the
user enter their real name and password once only. The session is then assigned to
the real user name and the session's .WIC file is copied to the real user's own folder.
We discovered that this process had a bug, as follows:

During the initial login, a session .WIC file is created for each user. When the
session was reassigned to another user name, the .WIC file was correctly copied to
that user's folder. However, the session .WIC file was not deleted from user folder
belonging to the initial user name. This has been fixed.

eCase 40979 The licensing system has been changed. A 6.2.0 license cannot be used with earlier
versions, and a pre-6.2.0 license cannot be used with v6.2.0. Similarly, the licensing
check in 6.2.0 that counts simultaneous users does not "see" earlier versions, and
pre-6.2.0 versions do not "see" v6.2.0 users. The UserStat program shows current
users on the network. This now sees only v6.2.0 users. The evaluation procedure is
different. In v6.2.0 it works like this:

▪ The regular versions of all the wIntegrate products are available from U2BC and
on the product CD. If these versions are not authorized they will run for ten days,
during which a countdown warning message is displayed.
The licensing dialog box is shown during installation and on the menus. So at any
time you can enter an evaluation license of a full license from U2BC.

▪ New for v6.2.0 is a Trial version available as a download from the U2 web site.
The licensing dialog box is not shown during installation or on the menus. The
trial version is automatically authorized for 60 days. During the last ten days, a
countdown warning is displayed.

eCase 41009 The Java client supports searching in the grid. However, the search text was only
found if the whole cell matched the given text. It is supposed to find the search text
even if it is only part of the text in the cell. This has been fixed.

eCase 41024 eCase 8493 in version 6.1.1 introduced the ability to paste Unicode characters into
the emulation screen by automatically converting them to equivalents that can
be handled by the U2 host. For example, Word's smart quotes are converted to
simple double quotes. The characters to be converted can be customized in the file
InputMap.txt in the Program Files\wIntegrate folder. There was an issue
where, if a character was set to be converted to null, a memory leak occurred. This
has been fixed.

eCase 41025 All wIntegrate version 6.1.3 and 6.2.0 applications are certified to work with Windows
7 64-bit. This includes the local install-version in addition to the wIntegrate Server
and thin clients.
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eCase 41026 All wIntegrate version 6.1.3 and 6.2.0 applications are certified to work with Windows
Server R2. This includes the local install-version in addition to the wIntegrate Server
and thin clients.

eCase 41059 The Authorization Key is entered with the Serial Number during installation. It
consists of twelve letters and numbers followed by the number of users it supports,
for example, Q1WE-AS2D-ZXC3-1. Optionally, an evaluation license of, say, 30 days
would also have "-E30" appended.

The Authorization Key contains information about the license, including the Serial
Number and the highest version of the product it supports. In the 6.2.0 release,
the Authorization key is generated in a different way. This is not apparent to users
from looking at the Key, but it means that a Key that works with version 6.2.0 and
later cannot work with releases before 6.2.0. All aspects of the product affected by
licensing have been changed accordingly.

When the program starts, it broadcasts a message to other instances of the program
running on the same network. (Please see the Administration Guide for more
information.) In previous releases, the broadcast was made on TCP/IP port 5005.
In 6.2.0, the port that is used is 55005. The UserStat program is affected by the
change of port. This is a stand-alone application that lets you click a button and see
a list of all wIntegrate users, according to who responded to its broadcast. In 6.2.0,
it broadcasts on the new TCP/IP port 55005, and so cannot show users of earlier
versions as these would not "see" the broadcast.

eCase 41188 Before the 6.2.0 release, wIntegrate shipped with version 3.1.0.0 of the U2 Device
Licensing DLL u2licn.dll. eCase 11054 describes an issue with version 3.1.0.0,
where Device Licensing failed when connecting with Citrix or Terminal Services
over a WAN or different subnets. Device licensing was not able to get the host name
when Citrix or Terminal Services environments were being used, and the server was
accessed by the client over a WAN, or when the client and server were on different
subnets. This was fixed in version 3.2.1.0 of u2Licn.dll, which is shipped with
wIntegrate 6.2.0.

eCase 41326 The licensing dialog box lets you enter the Serial Number and Authorization Key. It is
shown during installation, and is also available on the Start menu under wIntegrate.
The Key contains information about the license. In this release, when you have
entered the Key and tabbed away from the field, the dialog box shows the number of
users supported and the highest version of the product it supports. It shows the same
information when you show the dialog box, and a Key has been entered previously.

eCase 41413 It has always been possible to drop text between other applications, such as a word
processor and the wIntegrate screen. It is now possible to drag and drop files and
folders from, for example, the File Manager, on to controls in scripted dialog boxes.
The receiving control must support the Drop event.

eCase 41429 The wIntegrate Administrator is installed with the wIntegrate Server as part of
the thin client deployment. During development of v6.2.0, Symantec Anti-Virus
mistakenly reported a "Suspicious DLoader" virus in this application's executable
wIntAdm.exe. The wIntegrate Administrator is written entirely by Rocket Software
developers. It is a relatively simple program with no external code or binaries. The
code is essentially unchanged from the 6.1.3 release (Aug 2009) in which Symantec
did not find a virus when this version was released. The "Suspicious DLoader" virus
check was first introduced by Symantec on December 16, 2009. Their web page says
its damage level is low and it is easily removed. It also says legitimate files can be
misidentified and quarantined. We submitted this false positive to Symantec. They
responded that they will remove this detection from a future release of the product.
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eCase 41544 The program supports custom images in the splash screen and Help > About
dialog boxes. If VARs put images named OEM_ST.bmp and OEM.AB.bmp into the
Program Files\wIntegrate\Images file, then these images are used for the
splash screen and Help > About respectively. These dialog boxes normally display
license text in a black font. However, for past reasons of backward-compatibility,
when OEM images are used, the license text was shown as yellow. In this release, the
license text is always black, even if OEM images are used.

eCase 41603 When exporting data from a spreadsheet to the U2 host, each column in Excel should
normally go into a different attribute in the U2 data record. However, when exporting
data from an .XLS spreadsheet created by Excel 2003/2007, it was possible for two
cells in the spreadsheet to be concatenated together in the same U2 field. This could
happen because Excel has a recently introduced alternate way of storing column
numbers internally. The program did not always handle this correctly. This has been
fixed.

eCase 41617 wIntegrate 6.2.0 is certified to work with Microsoft Office 2010. Users of Dynamic Data
Exchange (DDE) should be aware that Microsoft Excel has an option in File > Options
> Advanced to Ignore other applications that use Dynamic Data Exchange. DDE
is a 16-bit technology. If you are still using it, you might want to consider replacing it
with Automation, the 32-bit equivalent.

eCase 41635 You can run the local version of the product with menus, dialog boxes, and messages
in Simplified Chinese. This is achieved by going into Setup > Application, Language,
and selecting Chinese in the drop-down list. You need to restart the program for this
change to take effect.

Similarly, the CD menu and installer for the local version can optionally be run in
Simplified Chinese. If you are running a Simplified Chinese version of Windows,
everything appears in this language by default. In this version, the resources (dialog
boxes, menus, and messages) have been updated to match internal changes to the
code. Recently added text is still in English.

eCase 41677 This is for the record only. Users should see no difference in usage. The technical
manuals such as the Client Scripting Reference and the Object Model Reference are
generated programmatically. This program has remained unchanged for many
years. It was rewritten for this release. Users should see no difference when using the
manuals.

eCase 41938 Controls in wIntegrate can be set to accept drag and drop text. When a file from
Windows Explorer was dragged and dropped onto a control, Windows Explorer could
crash. The was very rare and only happened under a specific set of circumstances. It
would happen if a file was dragged to a control when no other control in the session
had set the DragTarget property, and also other conditions were true.

The crash happened because wIntegrate was checking the data dragged to see
whether it was in wIntegrate's internal drag format, which is only registered if a
DragTarget has been set on any control. The program now checks whether the
internal drag format has been registered before using it. This has been fixed.

We also noticed that drag and drop events did not have access to the DialogBox
Event library. This is only required if developers choose to use routines in the library.
We changed the code so that drag and drop can access this library by default.
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eCase 42014 The Editor is installed when you select Developer Additions during installation. It
supports syntax coloring for scripts, host basic programs, and session .WIC files. The
Editor has been enhanced as follows:

▪ The "!" character is now recognized as beginning a comment, in the same way as
"*"

▪ Formatting of IF / END ELSE / END statements is improved when some lines have
comments appended

The Dialog Designer now supports double quotation marks in the Caption property of
those controls that have captions.

eCase 42037 Since the beginning of June 2010, we have seen a new crash in wIntegrate. We
believe that this is happening as a result of a Windows update. It happens when
wIntegrate is active, and the user shuts down Windows in the normal way. The user
sees a message “RPC Server not available,” followed by a "software exception"
dialog box reporting a crash in wInteg.exe.

It happens because Windows is now closing the Session Manager wIntegSM.exe
at an earlier stage of the Windows shutdown process. However, wIntegrate expects
it to still be available. This causes the crash. We have modified the program to
catch the exception, which means that the user does not see that the crash has
happened. However, if the user subsequently chooses to stop the shutdown of
Windows, wIntegrate will be left active but it will not work because it needs the
Session Manager, which has already stopped.



103

Notices
Edition

Publication date: November 2018
Book number: WIN-643-ALL-RN-01
Product version: Version 6.4.3

Copyright
© Rocket Software, Inc. or its affiliates 1996-2017. All Rights Reserved.

Trademarks

Rocket is a registered trademark of Rocket Software, Inc. For a list of Rocket registered trademarks go
to: www.rocketsoftware.com/about/legal. All other products or services mentioned in this document
may be covered by the trademarks, service marks, or product names of their respective owners.

Examples

This information might contain examples of data and reports. The examples include the names of
individuals, companies, brands, and products. All of these names are fictitious and any similarity to
the names and addresses used by an actual business enterprise is entirely coincidental.

License agreement

This software and the associated documentation are proprietary and confidential to Rocket Software,
Inc. or its affiliates, are furnished under license, and may be used and copied only in accordance with
the terms of such license.

Note:  This product may contain encryption technology. Many countries prohibit or restrict the
use, import, or export of encryption technologies, and current use, import, and export regulations
should be followed when exporting this product.

http://www.rocketsoftware.com/about/legal
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Corporate information
Rocket Software, Inc. develops enterprise infrastructure products in four key areas: storage, networks,
and compliance; database servers and tools; business information and analytics; and application
development, integration, and modernization.

Website: www.rocketsoftware.com

Rocket Global Headquarters
77 4th Avenue, Suite 100
Waltham, MA 02451-1468
USA

To contact Rocket Software by telephone for any reason, including obtaining pre-sales information
and technical support, use one of the following telephone numbers.

Country Toll-free telephone number

United States 1-855-577-4323
Australia 1-800-823-405
Belgium 0800-266-65
Canada 1-855-577-4323
China 400-120-9242
France 08-05-08-05-62
Germany 0800-180-0882
Italy 800-878-295
Japan 0800-170-5464
Netherlands 0-800-022-2961
New Zealand 0800-003210
South Africa 0-800-980-818
United Kingdom 0800-520-0439

Contacting Technical Support

The Rocket Community is the primary method of obtaining support. If you have current support and
maintenance agreements with Rocket Software, you can access the Rocket Community and report
a problem, download an update, or read answers to FAQs. To log in to the Rocket Community or to
request a Rocket Community account, go to www.rocketsoftware.com/support.

In addition to using the Rocket Community to obtain support, you can use one of the telephone
numbers that are listed above or send an email to support@rocketsoftware.com.

http://www.rocketsoftware.com
http://www.rocketsoftware.com/support
mailto:support@rocketsoftware.com
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